nim.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. #!/bin/bash
  2. # Slackware build script for nim
  3. # Maintained 2020-2021 by Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=nim
  24. VERSION=${VERSION:-1.4.8}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. GUI=${GUI:-yes}
  46. PGADMIN=${PGADMIN:-no}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $PRGNAM-$VERSION
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
  66. cd $PRGNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. COMP_FLAGS="$SLKCFLAGS" \
  74. ./build.sh
  75. bin/nim c -d:release koch
  76. ./koch tools -d:release
  77. ./install.sh pkg
  78. mkdir -p $PKG/usr
  79. mv pkg/nim/bin $PKG/usr/
  80. for fn in nimble nimsuggest nimgrep; do cp bin/$fn $PKG/usr/bin/; done
  81. mkdir -p $PKG/usr/lib
  82. mv pkg/nim/lib $PKG/usr/lib/nim
  83. mv pkg/nim/compiler $PKG/usr/lib/nim/
  84. mv pkg/nim/compiler.nimble $PKG/usr/lib/nim/compiler/
  85. mkdir -p $PKG/usr/include
  86. mv $PKG/usr/lib/nim/*.h $PKG/usr/include/
  87. mkdir -p $PKG/etc/nim
  88. mv pkg/nim/config/nim.cfg $PKG/etc/nim/nim.cfg.new
  89. mv pkg/nim/config/nimdoc.cfg $PKG/etc/nim/nimdoc.cfg.new
  90. mv pkg/nim/config/nimdoc.tex.cfg $PKG/etc/nim/nimdoc.tex.cfg.new
  91. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | \
  92. grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  93. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  94. cp -a \
  95. copying.txt \
  96. $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. mkdir -p $PKG/install
  99. cat $CWD/slack-desc > $PKG/install/slack-desc
  100. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  101. cd $PKG
  102. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE