maude.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130
  1. #!/bin/bash
  2. # Slackware build script for maude
  3. # Copyright (C) 2016 Roberto Metere, Newcastle Upon Tyne (UK)
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220323 bkw: Modified by SlackBuilds.org:
  23. # - add -j1 to the make command (parallel builds were failing).
  24. # - fix 32-bit build.
  25. # - de-uglify script a bit, use SRCNAM (sorry, it was unreadable).
  26. # - add CHECK=yes option.
  27. cd $(dirname $0) ; CWD=$(pwd)
  28. PRGNAM=maude
  29. VERSION=${VERSION:-3.1}
  30. BUILD=${BUILD:-1}
  31. TAG=${TAG:-_SBo}
  32. PKGTYPE=${PKGTYPE:-tgz}
  33. if [ -z "$ARCH" ]; then
  34. case "$( uname -m )" in
  35. i?86) ARCH=i586 ;;
  36. arm*) ARCH=arm ;;
  37. *) ARCH=$( uname -m ) ;;
  38. esac
  39. fi
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. SRCNAM=Maude
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  67. cd $PRGNAM-$VERSION
  68. unzip $CWD/Full-$SRCNAM-$VERSION.zip
  69. chown -R root:root .
  70. find -L . \
  71. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  72. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  73. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  74. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  75. # 20220323 bkw: patch from Debian, with thanks.
  76. [ "$ARCH" != "x86_64" ] && patch -p1 < $CWD/32-bit-fixes.patch
  77. CFLAGS="$SLKCFLAGS" \
  78. CXXFLAGS="$SLKCFLAGS" \
  79. ./configure \
  80. --prefix=/usr \
  81. --libdir=/usr/lib${LIBDIRSUFFIX} \
  82. --sysconfdir=/etc \
  83. --localstatedir=/var \
  84. --mandir=/usr/man \
  85. --without-cvc4 \
  86. --without-yices2 \
  87. --datadir=/usr/share/maude \
  88. --datarootdir=/usr/share/maude \
  89. --build=$ARCH-slackware-linux
  90. make -j1
  91. [ "${CHECK:-no}" = "yes" ] && make -j1 check
  92. make install DESTDIR=$PKG
  93. # Manually FULL maude
  94. cp full-${PRGNAM}31.maude $PKG/usr/share/maude/full-$PRGNAM.maude
  95. # Let maude find its own files (... maybe I'm doing something wrong in the compilation?)
  96. mkdir -p $PKG/etc/profile.d/
  97. echo "export MAUDE_LIB=/usr/share/maude/" > $PKG/etc/profile.d/maude.sh.new
  98. chmod 755 $PKG/etc/profile.d/maude.sh.new
  99. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  100. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  101. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  102. cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
  103. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  104. mkdir -p $PKG/install
  105. cat $CWD/slack-desc > $PKG/install/slack-desc
  106. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  107. cd $PKG
  108. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE