VisUAL.SlackBuild 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788899091929394959697
  1. #!/bin/bash
  2. # Slackware build script for VisUAL
  3. # Copyright 2017 Fernando Lopez Jr <fernando.lopezjr@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=VisUAL
  24. VERSION=${VERSION:-1.27}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ] ; then
  46. BASENAME=${BASENAME:-visual_1.27-1_i386}
  47. elif [ "$ARCH" = "x86_64" ]; then
  48. BASENAME=${BASENAME:-visual_1.27-1_amd64}
  49. else
  50. echo "$ARCH is not supported."
  51. exit 1
  52. fi
  53. set -e
  54. rm -rf $PKG
  55. mkdir -p $TMP $PKG $OUTPUT
  56. cd $TMP
  57. rm -rf $PRGNAM-$VERSION
  58. mkdir $PRGNAM-$VERSION
  59. cd $PRGNAM-$VERSION
  60. ar p $CWD/$BASENAME.deb data.tar.xz | tar xvJ
  61. install -D -t $PKG/opt/$PRGNAM -m0755 \
  62. usr/local/bin/visual/VisUAL.sh
  63. sed -i -e 's:../jre/bin/::' $PKG/opt/$PRGNAM/VisUAL.sh
  64. install -D -t $PKG/opt/$PRGNAM -m0644 \
  65. usr/local/bin/visual/icon.png
  66. install -D -t $PKG/opt/$PRGNAM/content -m0644 \
  67. usr/local/bin/visual/content/*
  68. install -D -t $PKG/usr/share/applications -m0644 \
  69. usr/share/applications/$PRGNAM.desktop
  70. sed -i -e "s:/usr/local/bin/visual/:/opt/$PRGNAM/:" \
  71. $PKG/usr/share/applications/$PRGNAM.desktop
  72. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  73. ln -s $PKG/opt/$PRGNAM/content/*_LICENSE.txt $PKG/usr/doc/$PRGNAM-$VERSION
  74. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  75. mkdir -p $PKG/install
  76. cat $CWD/slack-desc > $PKG/install/slack-desc
  77. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  78. cd $PKG
  79. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE