THE.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163
  1. #!/bin/bash
  2. # Slackware build script for The Hessling Editor
  3. # Copyright 2012-2022 Richard Narron, California, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=THE
  24. VERSION=${VERSION:-3.3RC8}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. TARFILE=the-3.3
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  37. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  38. exit 0
  39. fi
  40. TMP=${TMP:-/tmp/SBo}
  41. PKG=$TMP/package-$PRGNAM
  42. OUTPUT=${OUTPUT:-/tmp}
  43. if [ "$ARCH" = "i586" ]; then
  44. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i686" ]; then
  47. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. LIBDIRSUFFIX="64"
  52. else
  53. SLKCFLAGS="-O2"
  54. LIBDIRSUFFIX=""
  55. fi
  56. set -e
  57. rm -rf $PKG
  58. mkdir -p $TMP $PKG $OUTPUT
  59. cd $TMP
  60. rm -rf $PRGNAM-$VERSION $TARFILE
  61. tar xvf $CWD/$TARFILE.tar.gz
  62. mv $TARFILE $PRGNAM-$VERSION
  63. cd $PRGNAM-$VERSION
  64. chown -R root:root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  67. -o -perm 511 \) -exec chmod 755 {} \; -o \
  68. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  69. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  70. # make the ncurses version of THE and the documentation
  71. mkdir ncurses
  72. cd ncurses
  73. CFLAGS="$SLKCFLAGS" \
  74. CXXFLAGS="$SLKCFLAGS" \
  75. ../configure \
  76. --with-curses=ncurses \
  77. --with-rexx=regina \
  78. --build=$ARCH-slackware-linux \
  79. --docdir=/usr/doc/$PRGNAM-$VERSION \
  80. --libdir=/usr/lib${LIBDIRSUFFIX} \
  81. --localstatedir=/var \
  82. --mandir=/usr/man \
  83. --prefix=/usr \
  84. --sysconfdir=/etc
  85. make
  86. make install DESTDIR=$PKG
  87. rm -rf doc/html
  88. make html
  89. rm -f $PKG/usr/bin/the
  90. ln -fs the-con $PKG/usr/bin/the
  91. ln -fs the-con $PKG/usr/bin/nthe
  92. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
  93. install -m0644 the64.gif the64.png doc/html/*.html \
  94. $PKG/usr/doc/$PRGNAM-$VERSION/html
  95. cd $TMP/$PRGNAM-$VERSION
  96. install -m0644 COPYING FAQ HISTORY README* TODO \
  97. $PKG/usr/doc/$PRGNAM-$VERSION
  98. # Try to make the X11 version of THE by using PDCurses (XCurses)
  99. if ldconfig -p | grep -q libXCurses.so; then
  100. mkdir xcurses
  101. cd xcurses
  102. # for XCurses, create pdcurses-x11.pc pkg-config
  103. XLIBDIR=lib${LIBDIRSUFFIX}
  104. XVERSION=$(xcurses-config --version)
  105. mkdir -p pkgconfig
  106. sed -e "s/XLIBDIR/${XLIBDIR}/" \
  107. -e "s/XVERSION/${XVERSION}/" \
  108. < $CWD/libpdcurses-x11.pc \
  109. > pkgconfig/libpdcurses-x11.pc
  110. PKG_CONFIG_PATH=pkgconfig \
  111. CFLAGS="$SLKCFLAGS" \
  112. CXXFLAGS="$SLKCFLAGS" \
  113. ../configure \
  114. --with-curses=pdcurses-x11 \
  115. --with-rexx=regina \
  116. --build=$ARCH-slackware-linux \
  117. --docdir=/usr/doc/$PRGNAM-$VERSION \
  118. --libdir=/usr/lib${LIBDIRSUFFIX} \
  119. --localstatedir=/var \
  120. --mandir=/usr/man \
  121. --prefix=/usr \
  122. --sysconfdir=/etc
  123. make the-x11
  124. install -m0755 the-x11 $PKG/usr/bin
  125. ln -fs the-x11 $PKG/usr/bin/xthe
  126. fi
  127. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  128. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  129. install -m0644 $CWD/$PRGNAM.SlackBuild $PKG/usr/doc/$PRGNAM-$VERSION
  130. mkdir -p $PKG/install
  131. cat $CWD/slack-desc > $PKG/install/slack-desc
  132. cd $PKG
  133. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE