123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293 |
- #!/bin/bash
- # Slackware build script for xmms-ladspa
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- # Notes:
- # - The source includes its own ladspa.h, which is why ladspa_sdk isn't
- # listed in REQUIRES.
- # - Certain ladspa plugins will make xmms segfault when the xmms
- # plugin tries to enumerate all the plugins available. guitarix's
- # plugins are the only ones on my system that do this. All the
- # other SBo packages that install ladspa plugins seem OK, so the
- # "fix" for this is (for now anyway) just to have xmms-ladspa skip
- # any plugin with "guitarix" in its name.
- # - The source is called xmms_ladspa. I chose to use xmms-ladspa for
- # PRGNAM so it'll match all the other xmms-* builds on SBo.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=xmms-ladspa
- VERSION=${VERSION:-1.1}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- SRCNAM=${PRGNAM/-/_}
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # Dirty hack alert: guitarix's plugins cause xmms to segfault when trying
- # to configure the ladspa plugins.
- patch -p1 < $CWD/skip_guitarix.diff
- sed -i "s,-fPIC,& $SLKCFLAGS," Makefile
- make
- mkdir -p $PKG/usr/lib$LIBDIRSUFFIX/xmms/Effect
- install -m0755 -s ladspa.so $PKG/usr/lib$LIBDIRSUFFIX/xmms/Effect
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README PLUGINS COPYING ChangeLog $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|