rezound.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. #!/bin/bash
  2. # Slackware build script for rezound
  3. # Copyright 2015-2016 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=rezound
  24. VERSION=${VERSION:-0.13.1beta}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i486 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i486" ]; then
  46. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. # Define supported sound system. PULSE is the one enabled by default
  59. oss="--disable-oss" ; [ "${OSS:-no}" != "no" ] && oss="--enable-oss"
  60. alsa="--disable-alsa" ; [ "${ALSA:-no}" != "no" ] && alsa="--enable-alsa"
  61. port="--disable-portaudio" ; [ "${PORT:-no}" != "no" ] && port="--enable-portaudio"
  62. jack="--disable-jack" ; [ "${JACK:-no}" != "no" ] && jack="--enable-jack"
  63. pulse="--enable-pulse" ; [ "${PULSE:-yes}" != "yes" ] && pulse="--disable-pulse"
  64. set -e
  65. rm -rf $PKG
  66. mkdir -p $TMP $PKG $OUTPUT
  67. cd $TMP
  68. rm -rf $PRGNAM-$VERSION
  69. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  70. cd $PRGNAM-$VERSION
  71. chown -R root:root .
  72. find -L . \
  73. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  74. -o -perm 511 \) -exec chmod 755 {} \; -o \
  75. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  76. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  77. # Fix docs path
  78. sed -i "s:/doc/@PACKAGE@:/doc/@PACKAGE@-${VERSION}:g" Makefile.in
  79. # The national language support builds on 32bit but does not on 64bit.
  80. # I have no idea why, hence I just disabled it (--disable-nls).
  81. CFLAGS="$SLKCFLAGS" \
  82. CXXFLAGS="$SLKCFLAGS" \
  83. ./configure \
  84. --prefix=/usr \
  85. --libdir=/usr/lib${LIBDIRSUFFIX} \
  86. --sysconfdir=/etc \
  87. --localstatedir=/var \
  88. --disable-nls \
  89. --mandir=/usr/man \
  90. --docdir=/usr/doc/$PRGNAM-$VERSION \
  91. --build=$ARCH-slackware-linux \
  92. $oss \
  93. $alsa \
  94. $port \
  95. $jack \
  96. $pulse
  97. make
  98. make install DESTDIR=$PKG
  99. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  100. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  101. # Copy the man page, although it was meant for Debian
  102. mkdir -p $PKG/usr/man/man1
  103. cp packaging/debian/rezound.1 $PKG/usr/man/man1
  104. find $PKG/usr/man -type f -exec gzip -9 {} \;
  105. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  106. # Use our icon (48x48) and desktop file
  107. mkdir -p $PKG/usr/share/{applications,pixmaps}
  108. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  109. cp $CWD/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
  110. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  111. mkdir -p $PKG/install
  112. cat $CWD/slack-desc > $PKG/install/slack-desc
  113. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  114. cd $PKG
  115. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE