luxcorerender.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124
  1. #!/bin/bash
  2. # Slackware build script for luxrender
  3. # Copyright 2013 Giorgio Peron Campodarsego, PD, Italy
  4. # Copyright 2015-22 Klaatu Wellington, NZ
  5. #
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=luxcorerender
  26. SHORT=luxcore
  27. VERSION=${VERSION:-2.6}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" != "x86_64" ]; then
  46. echo "This package is available for x86_64 only."
  47. exit 1
  48. fi
  49. set -e
  50. rm -rf $PKG
  51. mkdir -p $TMP $PKG $OUTPUT
  52. cd $TMP
  53. rm -rf $PRGNAM-$VERSION
  54. mkdir $PRGNAM-$VERSION
  55. tar xvjf $CWD/$PRGNAM-v"$VERSION"-linux64.tar.bz2 \
  56. --strip-components=1 -C $PRGNAM-$VERSION
  57. cd $PRGNAM-$VERSION
  58. chown -R root:root .
  59. find -L . \
  60. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  61. -o -perm 511 \) -exec chmod 755 {} \; -o \
  62. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  63. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  64. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  65. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  66. ## install to opt
  67. mkdir $PKG/opt
  68. mv $TMP/$PRGNAM-$VERSION $PKG/opt/$PRGNAM-$VERSION
  69. # if OPENCL=yes, then set doinst.sh to rename dummy OpenCL
  70. # definition so Lux can find valid OpenCL device
  71. if [ $OPENCL ]; then
  72. cat <<EOF >> $CWD/doinst.sh
  73. if [ -e /etc/OpenCL/vendors/mesa.icd ]; then
  74. mv /etc/OpenCL/vendors/mesa.icd /etc/OpenCL/vendors/mesa.icd-dummy
  75. fi
  76. EOF
  77. fi
  78. # desktop conveniences
  79. mkdir -p $PKG/usr/share/applications
  80. cp $CWD/luxcoreui.desktop $PKG/usr/share/applications
  81. cp $CWD/pyluxcoretools.desktop $PKG/usr/share/applications
  82. # icons
  83. mkdir -p $PKG/usr/share/icons/hicolor/scalable/{mimetypes,apps}
  84. cp $CWD/application-x-$SHORT.svg \
  85. $PKG/usr/share/icons/hicolor/scalable/mimetypes
  86. cp $CWD/$SHORT.svg $PKG/usr/share/icons/hicolor/scalable/apps
  87. # mimetypes
  88. mkdir -p $PKG/usr/share/mime/application/
  89. # no front-end is provided for it, so
  90. # provide a command to the Python zipapp
  91. mkdir $PKG/usr/bin/
  92. cat $CWD/pyluxcoretools.sh > $PKG/usr/bin/pyluxcoretools
  93. chmod +x $PKG/usr/bin/pyluxcoretools
  94. # docs
  95. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  96. mv README.md AUTHORS.txt COPYING.txt $PKG/usr/doc/$PRGNAM-$VERSION
  97. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  98. cat $CWD/mime-"$SHORT".xml > $PKG/usr/doc/$PRGNAM-$VERSION/mime-"$SHORT".xml
  99. mkdir -p $PKG/install
  100. cat $CWD/slack-desc > $PKG/install/slack-desc
  101. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE