Pixie.SlackBuild 4.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141
  1. #!/bin/bash
  2. # Slackware build script for pixie
  3. # Copyright 2013 S. Randall Sawyer, Maine, USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220222 bkw: Modified by SlackBuilds.org: fix build on 15.0.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=Pixie
  25. VERSION=${VERSION:-2.2.6}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i486 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  37. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  38. exit 0
  39. fi
  40. TMP=${TMP:-/tmp/SBo}
  41. PKG=$TMP/package-$PRGNAM
  42. OUTPUT=${OUTPUT:-/tmp}
  43. if [ "$ARCH" = "i486" ]; then
  44. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i686" ]; then
  47. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. LIBDIRSUFFIX="64"
  52. else
  53. SLKCFLAGS="-O2"
  54. LIBDIRSUFFIX=""
  55. fi
  56. set -e
  57. rm -rf $PKG
  58. mkdir -p $TMP $PKG $OUTPUT
  59. cd $TMP
  60. rm -rf Pixie $PRGNAM-$VERSION
  61. tar xvf $CWD/$PRGNAM-src-$VERSION.tgz
  62. mv $PRGNAM $PRGNAM-$VERSION
  63. cd $PRGNAM-$VERSION
  64. chown -R root:root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  67. -exec chmod 755 {} \+ -o \
  68. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  69. -exec chmod 644 {} \+
  70. # Patch code for more accurate pointer casting
  71. patch -p1 < $CWD/Pixie-2.2.6-strict.patch
  72. # Fix a logical problem in configure for linking to the static version
  73. sed -i.r_static -e 's|--ldstaticflags|--ldflags|' configure
  74. # Fix building with bison-3 (thanks to cmuelle8 at Gentoo)
  75. # https://bugs.gentoo.org/show_bug.cgi?id=486148
  76. sed -i \
  77. -e '/define YY_DECL/ s/yylval/riblval/' \
  78. src/ri/rib.l
  79. patch -p1 < $CWD/Pixie.patch
  80. # 20220226 bkw: Slackware 15.0 hasn't got this header (and we didn't need it):
  81. sed -i '/include.*<sys\/sysctl\.h>/d' src/common/os.cpp
  82. # 20220226 bkw: newer STL, has min() and max(), which step on the ones
  83. # defined here. Rename.
  84. grep -rl '\<min *(' src | xargs sed -i 's,\<min *(,Min(,g'
  85. grep -rl '\<max *(' src | xargs sed -i 's,\<max *(,Max(,g'
  86. CFLAGS="$SLKCFLAGS" \
  87. CXXFLAGS="$SLKCFLAGS" \
  88. ./configure \
  89. --prefix=/usr \
  90. --mandir=/usr/man \
  91. --libdir=/usr/lib${LIBDIRSUFFIX} \
  92. --datadir=/usr/share \
  93. --disable-static \
  94. --enable-shared \
  95. --disable-static-fltk \
  96. --disable-selfcontained \
  97. --enable-openexr-threads
  98. make
  99. make install-strip DESTDIR=$PKG
  100. gzip -9 $PKG/usr/man/man*/*
  101. # Evidently, configure is somewhat broken:
  102. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/html
  103. cd $PKG/usr/share/doc/$PRGNAM
  104. # Move HTML files and directories
  105. mv *.* $(find . -type d -mindepth 1 -maxdepth 1) $PKG/usr/doc/$PRGNAM-$VERSION/html
  106. # Move remaining files - release files
  107. mv * $PKG/usr/doc/$PRGNAM-$VERSION/
  108. cd -
  109. # Prune directory now containing no doc files:
  110. rm -rf $PKG/usr/share/doc
  111. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  112. rm -f $PKG/usr/lib*/*.la
  113. mkdir -p $PKG/install
  114. cat $CWD/slack-desc > $PKG/install/slack-desc
  115. cd $PKG
  116. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE