viking.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131
  1. #!/bin/bash
  2. # Slackware build script for viking.
  3. # Copyright 2009-2011 Pierre Cazenave <pwcazenave {at} gmail [dot] com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. #
  23. # Maintained by David Spencer <baildon.research@googlemail.com>
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=viking
  26. VERSION=${VERSION:-1.6.2}
  27. BUILD=${BUILD:-2}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $PRGNAM-$VERSION
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.?z*
  66. cd $PRGNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # Patches ripped off from Arch (thanks!)
  74. patch -p1 < $CWD/remove-mapquest.patch
  75. patch -p0 < $CWD/viking-1.6.2-gpsd-3.18-fix.patch
  76. OPT_MAPNIK='--disable-mapnik'
  77. if [ ${MAPNIK:-no} = "yes" ]; then
  78. OPT_MAPNIK="--enable-mapnik"
  79. fi
  80. OPT_GEOCACHES='--disable-geocaches'
  81. if [ ${GEOCACHES:-no} = "yes" ]; then
  82. OPT_GEOCACHES="--enable-geocaches"
  83. fi
  84. CFLAGS="$SLKCFLAGS -w -Wl,--allow-multiple-definition" \
  85. CXXFLAGS="$SLKCFLAGS" \
  86. ./configure \
  87. --prefix=/usr \
  88. --sysconfdir=/etc \
  89. --localstatedir=/var \
  90. --libdir=/usr/lib${LIBDIRSUFFIX} \
  91. --docdir=/usr/doc/$PRGNAM-$VERSION \
  92. --mandir=/usr/man \
  93. --disable-scrollkeeper \
  94. $OPT_MAPNIK \
  95. $OPT_GEOCACHES \
  96. --build=$ARCH-slackware-linux
  97. make
  98. make install DESTDIR=$PKG
  99. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  100. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  101. # /usr/man is empty
  102. rm -rf $PKG/usr/man
  103. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  104. cp -a AUTHORS COPYING ChangeLog INSTALL NEWS README TODO \
  105. $PKG/usr/doc/$PRGNAM-$VERSION
  106. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  107. mkdir -p $PKG/install
  108. cat $CWD/slack-desc > $PKG/install/slack-desc
  109. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  110. cd $PKG
  111. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE