123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178 |
- #!/bin/bash
- # Slackware build script for VLC media player
- # Written by Andrea De Pasquale <andrea@de-pasquale.name>
- # Based on Eric Hameleers' Slackware build script,
- # modified to build VLC only, shared libraries needed.
- # Copyright (c) 2007,2008,2009,2010,2011 Eric Hameleers, Eindhoven, Netherlands
- # Copyright (c) 2014-2022 Christoph Willing, Brisbane, Australia
- # Copyright (c) 2022 Bill Kirkpatrick, Bay City, Texas, USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification is
- # permitted, provided that the following conditions are met:
- # 1. Redistribution of this script must retain the above copyright notice,
- # this list of conditions and the following disclaimer.
- # copies.
- #
- # THIS SOFTWARE IS PROVIDED "AS IS" AND ANY EXPRESSED OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED.
- # IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT,
- # INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING,
- # BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
- # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
- # CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT
- # LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN
- # WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE
- # POSSIBILITY OF SUCH DAMAGE.
- # -----------------------------------------------------------------------------
- # 20220215 bkw: Modified by SlackBuilds.org:
- # - stop the build if libebml is installed, since it will fail.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=vlc
- VERSION=${VERSION:-3.0.17.3}
- BUILD=${BUILD:-3}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- SLKLDFLAGS="-lrt"
- DOCS="ABOUT-NLS AUTHORS COPYING INSTALL NEWS README THANKS"
- # 20220215 bkw: this compiles for a long time, then fails, if libebml is
- # installed. Better to fail immediately and let the user know how to fix it.
- if [ "${FORCE:-no}" != "yes" ] && pkg-config --exists libebml; then
- cat <<EOF
- **********************************************************
- * Conflicting package found: libebml *
- **********************************************************
- * This build is known to fail when libebml is installed. *
- * Run "removepkg libebml", then re-run this script. *
- * You can reinstall libebml after vlc finishes building. *
- **********************************************************
- If you want to try building vlc anyway, export FORCE=yes
- in the environment.
- EOF
- exit 1
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.xz
- cd $PRGNAM-$VERSION
- sed -i '/DEPRECATED/s:^://:' modules/text_renderer/freetype/text_layout.c
- patch -p0 < $CWD/patch-dvdread-503.diff
- patch -p0 < $CWD/patch-dvdnav-503.diff
- patch -p0 < $CWD/patch-projectM-fontpath.diff
- patch -p0 < $CWD/patch_vlc_cache_gen.diff
- # Don't enable wayland by default
- wayland="--disable-wayland" ; [ "${WAYLAND:-no}" != "no" ] && wayland="--enable-wayland"
- # Enable vlc to be run as root
- runasroot=""; [ "${RUNASROOT:-no}" != "no" ] && runasroot="--enable-run-as-root"
- # Give the possibility to explicitly disable aom support
- aom=""; [ "${AOM:-yes}" = "no" ] && aom="--disable-aom"
- autoreconf -fiv
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \+ -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \+
- CFLAGS="$SLKCFLAGS" \
- CXXFLAGS="$SLKCFLAGS" \
- LDFLAGS="$SLKLDFLAGS" \
- ./configure \
- --prefix=/usr \
- --libdir=/usr/lib${LIBDIRSUFFIX} \
- --sysconfdir=/etc \
- --mandir=/usr/man \
- --docdir=/usr/doc/vlc-$VERSION \
- --localstatedir=/var \
- --build=$ARCH-slackware-linux \
- --enable-qt=5 \
- --enable-merge-ffmpeg \
- --disable-upnp \
- $wayland \
- $runasroot \
- $aom \
- make
- make DESTDIR=$PKG install
- mkdir -p $PKG/usr/man/man1
- gzip -9c doc/vlc.1 > $PKG/usr/man/man1/vlc.1.gz
- install -D -m0644 extras/analyser/vlc.vim $PKG/usr/share/vim/vimfiles/syntax/vlc.vim
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- find $PKG/usr/doc -type f -exec chmod 644 {} \;
- chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION/*
- find $PKG/usr/man -type f -name "*.?" -exec gzip -9f {} \;
- for i in $(find $PKG/usr/man -type l -name "*.?") ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
- | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null
- rm -f $PKG/usr/lib*/*.la
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- ###sbolint off
- sed -e s/%LIBDIRSUFFIX%/$LIBDIRSUFFIX/g $CWD/doinst.sh.in > $PKG/install/doinst.sh
- ###sbolint on
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|