mpv.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145
  1. #!/bin/bash
  2. # Slackware build script for mpv
  3. # Copyright 2015 John Vogel Corning, NY USA
  4. # Copyright 2017,2018 (versions 0.25.0-0.29.1) Andreas Guldstrand
  5. # Copyright 2020-2022 Christoph Willing Brisbane Australia
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=mpv
  26. VERSION=${VERSION:-0.34.1}
  27. WAF_VERSION=${WAF_VERSION:-2.0.20}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. # The SLKFLAGS aren't currently used. They do no harm and can
  49. # be left as a placeholder in case they are ever needed.
  50. if [ "$ARCH" = "i586" ]; then
  51. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "i686" ]; then
  54. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  55. LIBDIRSUFFIX=""
  56. elif [ "$ARCH" = "x86_64" ]; then
  57. SLKCFLAGS="-O2 -fPIC"
  58. LIBDIRSUFFIX="64"
  59. else
  60. SLKCFLAGS="-O2"
  61. LIBDIRSUFFIX=""
  62. fi
  63. set -e
  64. rm -rf $PKG
  65. mkdir -p $TMP $PKG $OUTPUT
  66. cd $TMP
  67. rm -rf $PRGNAM-$VERSION
  68. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  69. cd $PRGNAM-$VERSION
  70. cp $CWD/waf-$WAF_VERSION ./waf
  71. sed -i -e 's/python$/python3/' waf
  72. chmod +x waf
  73. chown -R root:root .
  74. find -L . \
  75. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  76. -o -perm 511 \) -exec chmod 755 {} \; -o \
  77. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  78. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  79. DOCS="Copyright LICENSE.GPL LICENSE.LGPL README.md RELEASE_NOTES VERSION"
  80. MANUAL="DOCS/*.md DOCS/*.rst DOCS/*.txt"
  81. # This leaves an opening for additional build options.
  82. BUILD_OPTS=${BUILD_OPTS:-""}
  83. PKG_CONFIG_PATH="/usr/lib${LIBDIRSUFFIX}/ffmpeg4/pkgconfig"
  84. export PKG_CONFIG_PATH
  85. # Setting CFLAGS and CXXFLAGS breaks configure.
  86. ./waf configure \
  87. --prefix=/usr \
  88. --libdir=/usr/lib${LIBDIRSUFFIX} \
  89. --confdir=/etc/$PRGNAM \
  90. --mandir=/usr/man \
  91. --docdir=/usr/doc/$PRGNAM-$VERSION \
  92. --enable-libmpv-shared \
  93. --enable-html-build \
  94. --enable-dvdnav \
  95. --enable-cdda \
  96. --enable-dvbin \
  97. $BUILD_OPTS
  98. ./waf build
  99. ./waf --destdir=$PKG install
  100. for f in $PKG/etc/mpv/*.conf ; do
  101. mv $f{,.new}
  102. done
  103. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" \
  104. | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  105. if [ -d $PKG/usr/man ]; then
  106. find $PKG/usr/man -type f -exec gzip -9 {} \;
  107. for i in $( find $PKG/usr/man -type l ) ; do
  108. ln -s $( readlink $i ).gz $i.gz
  109. rm $i
  110. done
  111. fi
  112. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  113. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  114. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION/manual
  115. for f in $MANUAL; do
  116. cp -a $f $PKG/usr/doc/$PRGNAM-$VERSION/manual/
  117. done
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. mkdir -p $PKG/install
  120. cat $CWD/slack-desc > $PKG/install/slack-desc
  121. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  122. cd $PKG
  123. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE