gpac.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. #!/bin/bash
  2. # Slackware Package Build Script for gpac
  3. # Home Page: https://gpac.wp.mines-telecom.fr/
  4. # Copyright (c) 2007-2017, Nishant Limbachia, Hoffman Estates, IL, USA
  5. # (nishant _AT_ mnspace _DOT_ net)
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of script must retain the above copyright notice,
  12. # this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  15. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  16. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  17. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
  18. # CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
  19. # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  20. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
  21. # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
  22. # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
  23. # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  24. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM="gpac"
  27. VERSION=${VERSION:-1.0.1}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. set -e
  49. if [ "$ARCH" = "i586" ]; then
  50. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "i686" ]; then
  53. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  54. LIBDIRSUFFIX=""
  55. elif [ "$ARCH" = "x86_64" ]; then
  56. SLKCFLAGS="-O2 -fPIC"
  57. LIBDIRSUFFIX="64"
  58. else
  59. SLKCFLAGS="-O2"
  60. LIBDIRSUFFIX=""
  61. fi
  62. ### wxwidgets support
  63. if [ "${WX_SUPPORT:-no}" = "no" ]; then
  64. wx_option="--disable-wx"
  65. else
  66. wx_option="--enable-wx"
  67. fi
  68. if [ "${AMR:-no}" = "no" ]; then
  69. amr_option="--disable-amr"
  70. else
  71. amr_option="--enable-amr"
  72. fi
  73. rm -rf $PKG
  74. mkdir -p $TMP $PKG $OUTPUT
  75. cd $TMP
  76. rm -fR $PRGNAM-$VERSION
  77. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  78. cd $PRGNAM-$VERSION
  79. chown -R root.root .
  80. find -L . \
  81. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  82. -o -perm 511 \) -exec chmod 755 {} \; -o \
  83. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  84. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  85. # configure doesn't have --libdir option.
  86. sed -i "s/^libdir=\".*\"$/libdir=\"lib$LIBDIRSUFFIX\"/" configure
  87. ./configure \
  88. --prefix=/usr \
  89. --mandir=/usr/man \
  90. --disable-opt \
  91. --enable-pic \
  92. --enable-pulseaudio \
  93. --cpu=${ARCH} \
  94. --extra-cflags="$SLKCFLAGS" \
  95. $wx_option \
  96. $amr_option
  97. make -j1
  98. make install DESTDIR=$PKG
  99. make install-lib DESTDIR=$PKG
  100. ### remove $PKG/usr/share/gpac directory
  101. ### only contains gpac.mp4 file which
  102. ### doesn't seem to play with mplayer
  103. #rm -fr $PKG/usr/share
  104. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  105. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  106. find $PKG/usr/man -type f -exec gzip -9 {} \;
  107. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  108. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  109. cp -a COPYING Changelog README.md \
  110. $PKG/usr/doc/$PRGNAM-$VERSION
  111. mkdir -p $PKG/install
  112. cat $CWD/slack-desc > $PKG/install/slack-desc
  113. cd $PKG
  114. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE