hhvm.SlackBuild 5.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160
  1. #!/bin/bash
  2. # Slackware build script for HHVM
  3. # Copyright 2015-2021 Eugene Wissner, Dachau, Germany
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=hhvm
  24. VERSION=${VERSION:-4.104.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. OPAM_STAMP="221708b"
  29. CARGO_BUILD="1"
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "x86_64" ]; then
  48. SLKCFLAGS="-O2 -fPIC"
  49. LIBDIRSUFFIX="64"
  50. else
  51. echo "$ARCH is not supported."
  52. exit 1
  53. fi
  54. set -e
  55. rm -rf $PKG
  56. mkdir -p $TMP $PKG $OUTPUT
  57. cd $TMP
  58. rm -rf $PRGNAM-$VERSION
  59. tar Jxvf $CWD/$PRGNAM-$VERSION.tar.xz
  60. cd $PRGNAM-$VERSION
  61. mkdir -p hphp/hack/facebook third-party/brotli/bundled_brotli-prefix/src
  62. mkdir -p hphp/hack/_build/opam
  63. tar Jxvf $CWD/hack-switch-$OPAM_STAMP.tar.xz -C hphp/hack/_build/opam
  64. # hhvm prepares an opam switch (an isolated envrionment with a specific OCaml
  65. # compiler version) during the build, it downloads and builds all dependencies.
  66. # To avoid doing this at runtime, I provide a prebuilt switch. Unfortunately
  67. # it contains references to absolute paths it has been built in. Therefore if
  68. # the user doesn't build in the standard directory, we put a link there, so
  69. # that opam can find binaries.
  70. if [ "$TMP" != '/tmp/SBo' ]
  71. then
  72. rm -rf /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam
  73. mkdir -p /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam
  74. ln -s $TMP/$PRGNAM-$VERSION/hphp/hack/_build/opam/hack-switch \
  75. /tmp/SBo/hhvm-$VERSION/hphp/hack/_build/opam/hack-switch
  76. fi
  77. tar Jxvf $CWD/cargo-home-$CARGO_BUILD.tar.xz -C hphp/hack
  78. tar Jxvf $CWD/brotli-4b5771be.tar.xz -C third-party/brotli/bundled_brotli-prefix/src
  79. install -m 0755 -D $CWD/opam-2.0.7-x86_64-linux \
  80. third-party/opam/opamDownload-prefix/src/opam-2.0.7-x86_64-linux
  81. install -m 0644 -D $CWD/rust-1.43.0-x86_64-unknown-linux-gnu.tar.gz \
  82. third-party/rustc/bundled_rust-prefix/src/rust-1.43.0-x86_64-unknown-linux-gnu.tar.gz
  83. install -m 0644 -D $CWD/fmt-6.1.2.zip third-party/fmt/fmt-prefix/src/fmt-6.1.2.zip
  84. install -m 0644 -D $CWD/fb-prod8-202010.tar.gz \
  85. third-party/fb-mysql/bundled_fbmysqlclient-prefix/src/fb-prod8-202010.tar.gz
  86. # The working directory is hphp/hack.
  87. cat << EOF > hphp/hack/facebook/fetch_opam2_repo_hack.sh
  88. #!/bin/sh
  89. cp $CWD/index-$OPAM_STAMP.tar.gz facebook/
  90. echo facebook/index-$OPAM_STAMP
  91. EOF
  92. chmod 0755 hphp/hack/facebook/fetch_opam2_repo_hack.sh
  93. patch -p1 --verbose -i $CWD/0001-Link-static-libiberty.patch
  94. chown -R root:root .
  95. find -L . \
  96. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  97. -o -perm 511 \) -exec chmod 755 {} \; -o \
  98. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  99. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  100. export CMAKE_PREFIX_PATH=`pwd`
  101. cmake \
  102. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  103. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  104. -DCMAKE_CXX_STANDARD=17 \
  105. -DCMAKE_INSTALL_PREFIX=/usr \
  106. -DCMAKE_INSTALL_LIBDIR=lib${LIBDIRSUFFIX} \
  107. -DENABLE_MCROUTER=false \
  108. -DENABLE_EXTENSION_IMAGICK=false \
  109. -DNON_DISTRIBUTABLE_BUILD=true \
  110. -DENABLE_LD_GOLD=true \
  111. -DUSE_JEMALLOC=true \
  112. -DFORCE_BUNDLED_LZ4=OFF \
  113. -DMYSQL_UNIX_SOCK_ADDR=/var/run/mysqld/mysqld.sock \
  114. -DCMAKE_BUILD_TYPE=Release .
  115. make || make -j1
  116. make install DESTDIR=$PKG
  117. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  118. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  119. mkdir -p $PKG/usr/man
  120. mv hphp/doc/man $PKG/usr/man/man1
  121. find $PKG/usr/man -type f -exec gzip -9 {} \;
  122. install -m 644 -D $CWD/etc/rc.hhvm $PKG/etc/rc.d/rc.hhvm.new
  123. install -m 644 -D $CWD/etc/server.ini $PKG/etc/hhvm/server.ini.new
  124. install -m 644 -D $CWD/etc/php.ini $PKG/etc/hhvm/php.ini.new
  125. mkdir -p $PKG/var/log/hhvm $PKG/usr/lib64/hhvm/extensions
  126. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  127. cp -a *.md LICENSE* hphp/doc/* $PKG/usr/doc/$PRGNAM-$VERSION
  128. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  129. mkdir -p $PKG/install
  130. cat $CWD/slack-desc > $PKG/install/slack-desc
  131. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  132. cd $PKG
  133. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE