electron.SlackBuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110
  1. #!/bin/bash
  2. # Slackware build script for electron
  3. # Copyright 2017 Dhaby Xiloj <slack.dhabyx@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=electron
  24. VERSION=${VERSION:-10.0.0_beta.1}
  25. SRCVER=$(echo $VERSION | tr _ -)
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. PKG_ARCH="ia32"
  48. elif [ "$ARCH" = "i686" ]; then
  49. PKG_ARCH="ia32"
  50. elif [ "$ARCH" = "x86_64" ]; then
  51. PKG_ARCH="x64"
  52. else
  53. echo "The package for $(uname -m) architecture is not supported.";
  54. exit 1
  55. fi
  56. set -e
  57. rm -rf $PKG
  58. mkdir -p $TMP $PKG $OUTPUT
  59. cd $TMP
  60. rm -rf $PRGNAM-$SRCVER
  61. mkdir $PRGNAM-$SRCVER
  62. cd $PRGNAM-$SRCVER
  63. unzip $CWD/$PRGNAM-v$SRCVER-linux-$PKG_ARCH.zip
  64. chown -R root:root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  67. -o -perm 511 \) -exec chmod 755 {} \; -o \
  68. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  69. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  70. # Manual installation
  71. mkdir -p $PKG/usr/share/$PRGNAM
  72. mkdir -p $PKG/usr/bin
  73. cp -a *.bin *.pak *.so $PRGNAM icudtl.dat version locales resources \
  74. $PKG/usr/share/$PRGNAM
  75. (
  76. cd $PKG/usr/bin
  77. ln -sf ../share/$PRGNAM/$PRGNAM ${PRGNAM}${VERSION}
  78. ln -sf ../share/$PRGNAM/$PRGNAM ${PRGNAM}
  79. )
  80. # Install prebuilt version for build binary apps
  81. if [ "${INSTALL_ZIP:-no}" != no ]; then
  82. mkdir -p $PKG/usr/share/$PRGNAM/release
  83. cp $CWD/$PRGNAM-v$SRCVER-linux-$PKG_ARCH.zip $PKG/usr/share/$PRGNAM/release
  84. fi
  85. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  86. cp -a \
  87. LICENSE LICENSES.chromium.html $CWD/README.Slackware \
  88. $PKG/usr/doc/$PRGNAM-$VERSION
  89. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  90. mkdir -p $PKG/install
  91. cat $CWD/slack-desc > $PKG/install/slack-desc
  92. cd $PKG
  93. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE