smath-studio.SlackBuild 2.7 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. #!/bin/bash
  2. # Slackware build script for SMath Studio
  3. # Copyright 2011-2014 Fridrich von Stauffenberg <cancellor2@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=smath-studio
  24. VERSION=${VERSION:-0.97.5346}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. ORIG_PRGNAM=SMathStudio
  29. ORIG_VERSION=$(sed 's/\./_/g' <<< $VERSION)
  30. ORIG_FILENAME=${ORIG_PRGNAM}Desktop.$ORIG_VERSION.Mono.tar.gz
  31. ARCH=noarch
  32. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  33. # the name of the created package would be, and then exit. This information
  34. # could be useful to other scripts.
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM
  41. OUTPUT=${OUTPUT:-/tmp}
  42. set -e
  43. rm -rf $PKG
  44. mkdir -p $OUTPUT $TMP $PKG/opt/$PRGNAM
  45. cd $PKG/opt/$PRGNAM
  46. tar xvf $CWD/$ORIG_FILENAME
  47. unzip $CWD/$ORIG_PRGNAM.Icons.zip
  48. chown -R root:root .
  49. find . -type d -exec chmod 755 {} \;
  50. find . -type f -exec chmod 644 {} \;
  51. for SIZE in 16 24 32 48 64 96 128 256; do
  52. mkdir -p $PKG/usr/share/icons/hicolor/$SIZE'x'$SIZE/apps
  53. mv SSLogo$SIZE.png $PKG/usr/share/icons/hicolor/$SIZE'x'$SIZE/apps/$PRGNAM.png
  54. done
  55. mkdir -p $PKG/usr/bin
  56. cat $CWD/$PRGNAM.sh > $PKG/usr/bin/$PRGNAM
  57. chmod 755 $PKG/usr/bin/$PRGNAM
  58. mkdir -p $PKG/usr/share/applications
  59. cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
  60. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  61. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  62. mkdir -p $PKG/install
  63. cat $CWD/slack-desc > $PKG/install/slack-desc
  64. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  65. cd $PKG
  66. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE