octave.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146
  1. #!/bin/bash
  2. # Slackware build script for octave
  3. # Copyright 2012-2022 Kyle Guinn <elyk03@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=octave
  24. VERSION=${VERSION:-6.4.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$(uname -m)" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$(uname -m) ;;
  33. esac
  34. fi
  35. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  36. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  37. exit 0
  38. fi
  39. TMP=${TMP:-/tmp/SBo}
  40. PKG=$TMP/package-$PRGNAM-$VERSION
  41. OUTPUT=${OUTPUT:-/tmp}
  42. DOCS="AUTHORS BUGS CITATION COPYING ChangeLog INSTALL* NEWS README"
  43. if [ "$ARCH" = "i486" ]; then
  44. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. # Use GraphicsMagick by default. Fall back on ImageMagick from the full
  60. # Slackware install if it's not present. Requires a patch for this bug:
  61. # https://savannah.gnu.org/bugs/?49653
  62. #
  63. # GraphicsMagick is default due to the fact that the Octave devs mainly test
  64. # with that, and went several releases before noticing ImageMagick was broken.
  65. # If ImageMagick doesn't work, install GraphicsMagick, or set MAGICK="".
  66. MAGICK=${MAGICK-GraphicsMagick}
  67. if [ -n "$MAGICK" ] && ! pkg-config --exists $MAGICK; then
  68. MAGICK=ImageMagick
  69. fi
  70. if [ -n "$MAGICK" ]; then
  71. MAGICK="--with-magick=$MAGICK"
  72. fi
  73. set -e
  74. rm -rf $PKG
  75. mkdir -p $TMP $PKG $OUTPUT
  76. cd $TMP
  77. rm -rf $PRGNAM-$VERSION
  78. tar xvf $CWD/$PRGNAM-$VERSION.tar.lz
  79. cd $PRGNAM-$VERSION
  80. chown -R root:root .
  81. chmod -R u+w,go-w,a+rX-st .
  82. patch -p1 < $CWD/patches/imagemagick.diff # https://savannah.gnu.org/bugs/?49653
  83. patch -p1 < $CWD/patches/atlas-lib-rename.diff
  84. autoreconf -vif
  85. # Avoid rebuilding the documentation by making stamp-vti newer than its
  86. # dependencies (in particular ./configure, which we may need to patch).
  87. # If you live far enough east or west that the date contained in version.texi
  88. # does not match that file's timestamp when printed accounting for your
  89. # timezone, then the docs get rebuilt with your local date.
  90. #
  91. # The TeX environment in Slackware 14.1 fails to build the DVI and PDF
  92. # targets in Octave 3.8.1. Maybe it works with a recent version of TeXLive?
  93. find . -name stamp-vti -exec touch {} +
  94. ./configure \
  95. --prefix=/usr \
  96. --libdir=/usr/lib${LIBDIRSUFFIX} \
  97. --sysconfdir=/etc \
  98. --localstatedir=/var \
  99. --mandir=/usr/man \
  100. --infodir=/usr/info \
  101. --docdir=/usr/doc/$PRGNAM-$VERSION \
  102. --disable-dependency-tracking \
  103. --with-openssl=auto \
  104. ${MAGICK} \
  105. --build=$ARCH-slackware-linux \
  106. CFLAGS="$SLKCFLAGS" \
  107. CXXFLAGS="$SLKCFLAGS" \
  108. FFLAGS="$SLKCFLAGS" \
  109. make
  110. make check
  111. make install-strip DESTDIR=$PKG
  112. find $PKG/usr/lib${LIBDIRSUFFIX} -name '*.la' -delete
  113. find $PKG/usr/man -type f -exec gzip -9 {} +
  114. rm -f $PKG/usr/info/dir
  115. gzip -9 $PKG/usr/info/*.info*
  116. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  117. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. mkdir -p $PKG/install
  120. cat $CWD/slack-desc > $PKG/install/slack-desc
  121. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  122. cd $PKG
  123. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE