123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122 |
- #!/bin/bash
- # Slackware build script for megax (formerly 'megacc')
- # This takes the place of "megacc" in 2018, as it includes also the GUI
- # of the program (megax) in addition to megacc.
- # Copyright 2017-2020 Petar Petrov slackalaxy@gmail.com
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=megax
- VERSION=${VERSION:-10.2.5_1}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- DEBVER=$(echo $VERSION | tr _ -)
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i386 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i386" ] || [ "$ARCH" = "i486" ] || [ "$ARCH" = "i586" ] || [ "$ARCH" = "i686" ]; then
- LIBDIRSUFFIX=""
- DEBARCH="i386"
- elif [ "$ARCH" = "x86_64" ]; then
- LIBDIRSUFFIX="64"
- DEBARCH="amd64"
- else
- printf "\n\n$ARCH is not supported... \n"
- exit 1
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- mkdir $PRGNAM-$VERSION
- cd $PRGNAM-$VERSION
- ar p $CWD/${PRGNAM}_${DEBVER}_${DEBARCH}.deb data.tar.xz | tar xJv
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- # Fix path in runmega.sh for x86_64
- sed -i "s|/usr/lib/megax|/usr/lib${LIBDIRSUFFIX}/megax|g" usr/lib/$PRGNAM/runmega.sh
- # Place things in /usr/lib and just create symlinks later.
- # This is what Debian's and RedHat's packages do.
- mkdir -p $PKG/usr/lib${LIBDIRSUFFIX}
- cp -a usr/lib/$PRGNAM $PKG/usr/lib${LIBDIRSUFFIX}
- # Copy man pages to their proper place.
- cp -a usr/local/share/man $PKG/usr
- mkdir -p $PKG/usr/bin
- cd $PKG/usr/bin
- ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/megacc
- ln -s ../lib${LIBDIRSUFFIX}/$PRGNAM/runmega.sh megax
- cd -
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- # Menu entry for MEGA X, use our .desktop file
- mkdir -p $PKG/usr/share/{applications,pixmaps}
- cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
- cp usr/share/pixmaps/mega.png $PKG/usr/share/pixmaps/megax.png
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|