meep.SlackBuild 4.2 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140
  1. #!/bin/bash
  2. # Slackware build script for meep
  3. # Copyright 2019 Paul Kinsler, U.K.
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=meep
  24. VERSION=${VERSION:-1.17.1}
  25. BUILD=${BUILD:-2}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. # change annoying underscores into hyphens
  59. SVERSION=$(echo $VERSION | tr '_' '-')
  60. # make a custom list of doc files in advance
  61. DOCFILES="AUTHORS COPYRIGHT LICENSE TODO NEWS.md"
  62. set -e
  63. rm -rf $PKG
  64. mkdir -p $TMP $PKG $OUTPUT
  65. cd $TMP
  66. rm -rf $PRGNAM-$SVERSION
  67. tar xvf $CWD/$PRGNAM-$SVERSION.tar.gz
  68. cd $PRGNAM-$SVERSION
  69. chown -R root:root .
  70. find -L . \
  71. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  72. -o -perm 511 \) -exec chmod 755 {} \; -o \
  73. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  74. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  75. # if there is no configure script, try to build one!
  76. if [ ! -f ./configure ] ; then
  77. ./autogen.sh
  78. fi
  79. LOCALCONFIGS=
  80. XDBFILE=/etc/sbo_pkg_options.conf
  81. if [ -f ${XDBFILE} ] ; then
  82. LOCALCONFIGS=${LOCALCONFIGS}" "$(grep "^${PRGNAM}:" ${XDBFILE} | grep -v '^#' | awk -F: '{print$2}')
  83. echo Build options selected by file: LOCALCONFIGS=${LOCALCONFIGS}
  84. fi
  85. if [ -n "${SBOPTIONS_MEEP}" ] ; then
  86. LOCALCONFIGS=${LOCALCONFIGS}" "${SBOPTIONS_MEEP}
  87. echo Build options selected by environment: LOCALCONFIGS=${LOCALCONFIGS}
  88. fi
  89. # check for the Atlas replacement for blas; if the libraries are found,
  90. # add the configure option accordingly
  91. if [ -f /usr/lib/libatlas.a ] ; then
  92. if [ -f /usr/lib/libatlas.so ] ; then
  93. echo "NOTICE: libatlas was found, configure --with-blas=atlas"
  94. LOCALCONFIGS=${LOCALCONFIGS}" --with-blas=atlas"
  95. fi
  96. fi
  97. CFLAGS="$SLKCFLAGS" \
  98. CPPFLAGS="$SLKCFLAGS" \
  99. ./configure \
  100. --prefix=/usr \
  101. --mandir=/usr/man \
  102. --libdir=/usr/lib${LIBDIRSUFFIX} \
  103. --docdir=/usr/doc/$PRGNAM-$VERSION \
  104. --build=$ARCH-slackware-linux \
  105. $LOCALCONFIGS
  106. make
  107. make install DESTDIR=$PKG
  108. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  109. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  110. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  111. install -m 0644 $DOCFILES $PKG/usr/doc/$PRGNAM-$VERSION
  112. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  113. rm -f $PKG/usr/lib*/*.la
  114. mkdir -p $PKG/install
  115. cat $CWD/slack-desc > $PKG/install/slack-desc
  116. cd $PKG
  117. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE