grace.SlackBuild 4.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137
  1. #!/bin/bash
  2. # Slackware build script for grace
  3. # Written by B. Jogai <jogaib {at} comcast [dot] net>
  4. # Substantially modified by Robby Workman <rworkman@slackware.com>
  5. # Updated by Fellype do Nascimento <fellype (at) gmail (dot) com
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=grace
  25. VERSION=${VERSION:-5.1.25}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-"_SBo"}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-"/tmp/SBo"}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-"/tmp"}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$VERSION
  64. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  65. cd $PRGNAM-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  69. -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. # Fix paths to docs in src/xmgrace.c
  73. sed -i "s%/usr/share/doc/packages/%/usr/lib${LIBDIRSUFFIX}/%g" src/xmgrace.c
  74. CFLAGS="$SLKCFLAGS" \
  75. ./configure \
  76. --prefix=/usr \
  77. --bindir=/usr/bin \
  78. --libdir=/usr/lib${LIBDIRSUFFIX} \
  79. --mandir=/usr/man \
  80. --enable-grace-home=/usr/lib${LIBDIRSUFFIX}/xmgrace \
  81. --with-x \
  82. --with-printcmd="lpr" \
  83. --with-helpviewer="firefox %s" \
  84. --build=$ARCH-slackware-linux
  85. make
  86. make DESTDIR=$PKG install
  87. # Set up the links for /usr/bin, /usr/include, and /usr/lib
  88. make DESTDIR=$PKG install links
  89. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  90. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  91. # Fix hardcoding of /usr/lib in the "links" target
  92. if [ "$ARCH" = "x86_64" ]; then
  93. mv $PKG/usr/lib/*.a $PKG/usr/lib${LIBDIRSUFFIX}
  94. rmdir $PKG/usr/lib 2>/dev/null || true
  95. fi
  96. # Add desktop menu entries
  97. mkdir -p $PKG/usr/share/{applications,pixmaps}
  98. cat $CWD/xmgrace.png > $PKG/usr/share/pixmaps/xmgrace.png
  99. cat $CWD/xmgrace.desktop > $PKG/usr/share/applications/xmgrace.desktop
  100. mkdir -p $PKG/usr/doc
  101. mv $PKG/usr/lib${LIBDIRSUFFIX}/xmgrace/doc $PKG/usr/doc/$PRGNAM-$VERSION
  102. cp -a CHANGES ChangeLog README DEVELOPERS LICENSE \
  103. $PKG/usr/doc/$PRGNAM-$VERSION
  104. find $PKG/usr/doc/$PRGNAM-$VERSION -type f -exec chmod 644 {} \;
  105. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  106. ( cd $PKG/usr/lib${LIBDIRSUFFIX}/xmgrace # now make the compat symlink
  107. ln -s ../../doc/$PRGNAM-$VERSION doc
  108. )
  109. rm -f $PKG/usr/man/man1/*
  110. cp -a $PKG/usr/doc/$PRGNAM-$VERSION/*.1 $PKG/usr/man/man1
  111. gzip -9 $PKG/usr/man/man1/*.?
  112. mkdir -p $PKG/install
  113. cat $CWD/slack-desc > $PKG/install/slack-desc
  114. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  115. cd $PKG
  116. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE