finchtv.SlackBuild 3.1 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485868788
  1. #!/bin/bash
  2. # Slackware build script for finchtv
  3. # Copyright 2015-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=finchtv
  24. VERSION=${VERSION:-1.3.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCVER=1_3_1
  29. ARCH=i386 # This will work on a stock Slackware64 as well.
  30. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  31. # the name of the created package would be, and then exit. This information
  32. # could be useful to other scripts.
  33. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  34. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  35. exit 0
  36. fi
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. set -e
  41. rm -rf $PKG
  42. mkdir -p $TMP $PKG $OUTPUT
  43. cd $TMP
  44. rm -rf ${PRGNAM}_${SRCVER}
  45. tar xvf $CWD/${PRGNAM}_${SRCVER}.tar.gz
  46. cd ${PRGNAM}_${SRCVER}
  47. chown -R root:root .
  48. find -L . \
  49. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  50. -o -perm 511 \) -exec chmod 755 {} \; -o \
  51. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  52. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  53. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  54. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  55. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  56. mkdir -p $PKG/usr/share/$PRGNAM
  57. cp -a SampleData $PKG/usr/share/$PRGNAM
  58. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  59. cp -a Help License.txt ReleaseNotes.txt $PKG/usr/doc/$PRGNAM-$VERSION
  60. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  61. cat $CWD/COMPANY > $PKG/usr/doc/$PRGNAM-$VERSION/COMPANY
  62. cat $CWD/CONTACT > $PKG/usr/doc/$PRGNAM-$VERSION/CONTACT
  63. cat $CWD/PRIVACY > $PKG/usr/doc/$PRGNAM-$VERSION/PRIVACY
  64. mkdir -p $PKG/usr/share/{applications,pixmaps}
  65. cp $CWD/$PRGNAM.desktop $PKG/usr/share/applications
  66. cp Help/media/FinchTV_Mac_App.png $PKG/usr/share/pixmaps/$PRGNAM.png
  67. mkdir -p $PKG/install
  68. cat $CWD/slack-desc > $PKG/install/slack-desc
  69. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  70. cd $PKG
  71. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE