fiji.SlackBuild 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162
  1. #!/bin/bash
  2. # Slackware build script for fiji
  3. # Copyright 2018-2021 Petar Petrov slackalaxy@gmail.com
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=fiji
  24. VERSION=${VERSION:-20201104_1356}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. DIRNAM=Fiji.app
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i386 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. set -e
  47. # Stop if arch is not supported
  48. if [ "$ARCH" != "i386" ] && [ "$ARCH" != "x86_64" ]; then
  49. printf "\n\n$ARCH is not supported... \n"
  50. exit 1
  51. fi
  52. # Determine suffix
  53. if [ "$ARCH" = "x86_64" ]; then
  54. SUFFIX=linux64
  55. else
  56. SUFFIX=linux32
  57. fi
  58. rm -rf $PKG
  59. mkdir -p $TMP $PKG $OUTPUT
  60. cd $TMP
  61. rm -rf $DIRNAM
  62. tar xvf $CWD/${PRGNAM}-$SUFFIX.tar.gz
  63. cd $DIRNAM
  64. chown -R root:root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  67. -o -perm 511 \) -exec chmod 755 {} \; -o \
  68. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  69. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  70. # Rename the binary we need
  71. mv ImageJ-$SUFFIX $PRGNAM
  72. # We will put here two tools, so they are not run at startup.
  73. mkdir -p unused
  74. cd unused
  75. # Remove the check for required updates. If you want it, comment out
  76. # the next line. You can "enable" it any time by just placing it in the
  77. # plugins/Scripts/Plugins/AutoRun/ folder.
  78. mv ../plugins/Scripts/Plugins/AutoRun/Check_Required_Update_Sites.js .
  79. # We do not want updates when the program is installed. As above, it
  80. # is your system, so if you want this functionality, then comment out
  81. # the line below. You can always "enable" it, by placing it in the jars
  82. # folder.
  83. mv ../jars/imagej-updater-* .
  84. cd ..
  85. # Update plugins, so that the latest are included in the package. This
  86. # will download stuff during the package creation, something that is
  87. # against the policy of SlackBuilds.org. However, it is _your_ system,
  88. # so if you _really_ want this, uncomment the line below.
  89. # ./$PRGNAM --update list-local-only
  90. # Copy the folders, db.xml and the renamed binary to /opt
  91. mkdir -p $PKG/opt/$PRGNAM
  92. cp -a \
  93. Contents \
  94. images \
  95. jars \
  96. java \
  97. lib \
  98. luts \
  99. macros \
  100. plugins \
  101. retro \
  102. scripts \
  103. db.xml.gz \
  104. $PRGNAM \
  105. $PKG/opt/$PRGNAM
  106. if [ "$ARCH" = "x86_64" ]; then
  107. cp -a \
  108. licenses \
  109. $PKG/opt/$PRGNAM
  110. fi
  111. # If a file called "ImageJ2.desktop" is not present in the directory
  112. # of fiji, it will create (and re-create it if you delete it) the file
  113. # "~/.local/share/applications/ImageJ2.desktop" upon start. So, let it
  114. # have its desktop file. This is a very stupid workaround, but it is
  115. # really the best I could think of. At first I thought that deleting
  116. # "plugins/Scripts/Plugins/Utilities/Create_Desktop_Icon.bsh" will do
  117. # the trick, but no...
  118. cp $CWD/ImageJ2.desktop $PKG/opt/$PRGNAM
  119. # Install the simple wrapper
  120. install -D -m755 $CWD/$PRGNAM $PKG/usr/bin/$PRGNAM
  121. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  122. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  123. mkdir -p $PKG/usr/share/{applications,pixmaps}
  124. cp $CWD/ImageJ2.desktop $PKG/usr/share/applications
  125. cp images/icon.png $PKG/usr/share/pixmaps/$PRGNAM.png
  126. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  127. cp -a README.md WELCOME.md $PKG/usr/doc/$PRGNAM-$VERSION
  128. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  129. cat $CWD/References > $PKG/usr/doc/$PRGNAM-$VERSION/References
  130. mkdir -p $PKG/install
  131. cat $CWD/slack-desc > $PKG/install/slack-desc
  132. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  133. cd $PKG
  134. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE