123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130 |
- #!/bin/bash
- # Slackware build script for equalx
- # Copyright 2015 Charles E. Kauffman
- # Copyright 2020 B. Watson
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Now maintained by B. Watson <yalhcru@gmail.com>
- # 20210802 bkw: BUILD=3, update for qt5 on -current.
- # 20200101 bkw:
- # - take over maintenance
- # - BUILD=2
- # - fix default paths for applications (gs, pdflatex, pdftocairo)
- # - actually use SLKCFLAGS
- # - strip binary
- # - use a .desktop file that validates
- # - minor cleanups/etc in script, slack-desc, README
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=equalx
- VERSION=${VERSION:-0.7.1}
- BUILD=${BUILD:-3}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
- cd $PRGNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # Note: patches are gzipped because they have a mix of \n and \r\n
- # line endings. git can have issues with that.
- # Make sure the application can find the external binaries it runs,
- # without defaulting to silly things like .exe files. The patch actually
- # makes it look for pdflatex in both places it might be found (/usr/bin
- # for texlive, /usr/share/texmf/bin for tetex).
- zcat $CWD/externpaths.diff.gz | patch -p1
- zcat $CWD/qt5fix.diff.gz | patch -p1
- CFLAGS="$SLKCFLAGS" CXXFLAGS="$SLKCFLAGS" qmake-qt5
- sed -i "s,-O2,$SLKCFLAGS," Makefile
- make
- # No install target in .pro file, do it manually.
- mkdir -p \
- $PKG/usr/doc/$PRGNAM-$VERSION \
- $PKG/usr/bin \
- $PKG/usr/man/man1 \
- $PKG/usr/share/pixmaps \
- $PKG/usr/share/applications
- install -s -m0755 -oroot -groot $PRGNAM $PKG/usr/bin
- gzip -9c < $PRGNAM.1 > $PKG/usr/man/man1/$PRGNAM.1.gz
- cp -a resources/icons/equalx/equalx-64x64.png $PKG/usr/share/pixmaps
- cp -a LICENSE README THANKS changelog $PKG/usr/doc/$PRGNAM-$VERSION
- # Edited version of the .desktop that actually validates.
- cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|