edsim51di.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. #!/bin/bash
  2. # Slackware build script for EdSim51Di
  3. # Copyright 2014 R. S. Ananda Murthy, Mysore, India
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=edsim51di
  24. VERSION=${VERSION:-2.1.20}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. STARTDIR=$(pwd)
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM
  64. unzip $CWD/$PRGNAM.zip
  65. cd $PRGNAM
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. mkdir -p "$PKG/usr/share/$PRGNAM/lib" \
  73. "$PKG/usr/share/applications" \
  74. "$PKG/usr/share/icons/hicolor/48x48/apps" \
  75. "$PKG/usr/bin" \
  76. "$PKG/usr/doc/$PRGNAM-$VERSION"
  77. install -D -m644 $PRGNAM.jar $PKG/usr/share/$PRGNAM/
  78. install -D -m644 ./lib/edsim51sh.jar $PKG/usr/share/$PRGNAM/lib/
  79. install -D -m644 $STARTDIR/$PRGNAM.png $PKG/usr/share/icons/hicolor/48x48/apps/
  80. install -D -m644 $STARTDIR/license.txt $PKG/usr/doc/$PRGNAM-$VERSION/
  81. cat $STARTDIR/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  82. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  83. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  84. mkdir -p $PKG/install
  85. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  86. cat $CWD/slack-desc > $PKG/install/slack-desc
  87. cat <<EOF > $PKG/usr/share/applications/$PRGNAM.desktop
  88. [Desktop Entry]
  89. Name=Edsim51DI
  90. Comment=An educational tool for learning 8051 microcontroller
  91. Exec=edsim51di
  92. Icon=edsim51di
  93. Terminal=false
  94. Type=Application
  95. Categories=Education
  96. StartupNotify=false
  97. EOF
  98. cat <<EOF > $PKG/usr/bin/edsim51di
  99. #!/bin/bash
  100. #execute edsim51di jar file
  101. exec java -jar /usr/share/edsim51di/edsim51di.jar
  102. EOF
  103. chmod +x $PKG/usr/bin/edsim51di
  104. cd $PKG
  105. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE