cld2.SlackBuild 4.9 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142
  1. #!/bin/bash
  2. # SlackBuild script for cld2
  3. # Copyright 2013 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use in source and binary forms, with or without
  7. # modification, are permitted provided that the following conditions are
  8. # met:
  9. #
  10. # * Redistributions of source code must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  14. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  15. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  16. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  17. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  19. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  20. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  21. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  22. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  23. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=cld2
  26. VERSION=${VERSION:-20150820}
  27. SRCREV=b56fa78a2fe44ac2851bae5bf4f4693a0644da7b
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i586 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$SRCREV
  66. tar xvf $CWD/$PRGNAM-$SRCREV.tar.gz
  67. cd $PRGNAM-$SRCREV
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. ( cd internal
  75. g++ -shared $SLKCFLAGS -std=c++98 \
  76. cldutil.cc cldutil_shared.cc compact_lang_det.cc compact_lang_det_hint_code.cc \
  77. compact_lang_det_impl.cc debug.cc fixunicodevalue.cc \
  78. generated_entities.cc generated_language.cc generated_ulscript.cc \
  79. getonescriptspan.cc lang_script.cc offsetmap.cc scoreonescriptspan.cc \
  80. tote.cc utf8statetable.cc \
  81. cld_generated_cjk_uni_prop_80.cc cld2_generated_cjk_compatible.cc \
  82. cld_generated_cjk_delta_bi_4.cc generated_distinct_bi_0.cc \
  83. cld2_generated_quadchrome_2.cc cld2_generated_deltaoctachrome.cc \
  84. cld2_generated_distinctoctachrome.cc cld_generated_score_quad_octa_2.cc \
  85. -o libcld2.so
  86. g++ -shared $SLKCFLAGS -std=c++98 \
  87. cldutil.cc cldutil_shared.cc compact_lang_det.cc compact_lang_det_hint_code.cc \
  88. compact_lang_det_impl.cc debug.cc fixunicodevalue.cc \
  89. generated_entities.cc generated_language.cc generated_ulscript.cc \
  90. getonescriptspan.cc lang_script.cc offsetmap.cc scoreonescriptspan.cc \
  91. tote.cc utf8statetable.cc \
  92. cld_generated_cjk_uni_prop_80.cc cld2_generated_cjk_compatible.cc \
  93. cld_generated_cjk_delta_bi_32.cc generated_distinct_bi_0.cc \
  94. cld2_generated_quad0122.cc cld2_generated_deltaocta0122.cc \
  95. cld2_generated_distinctocta0122.cc cld_generated_score_quad_octa_0122.cc \
  96. -o libcld2_full.so
  97. g++ $SLKCFLAGS -std=c++98 \
  98. compact_lang_det_test.cc -I. -L. libcld2_full.so \
  99. -o cld2
  100. install -D -m 0755 cld2 $PKG/usr/bin/cld2
  101. install -D -m 0755 libcld2.so $PKG/usr/lib${LIBDIRSUFFIX}/libcld2.so
  102. install -D -m 0755 libcld2_full.so $PKG/usr/lib${LIBDIRSUFFIX}/libcld2_full.so
  103. )
  104. # install header files
  105. mkdir -p $PKG/usr/include/cld2/{internal,public}
  106. ( cd internal
  107. cp generated_language.h generated_ulscript.h integral_types.h lang_script.h $PKG/usr/include/cld2/internal
  108. )
  109. ( cd public
  110. cp compact_lang_det.h encodings.h $PKG/usr/include/cld2/public
  111. )
  112. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  113. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  114. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  115. cp -a \
  116. LICENSE README.md \
  117. $PKG/usr/doc/$PRGNAM-$VERSION
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. mkdir -p $PKG/install
  120. cat $CWD/slack-desc > $PKG/install/slack-desc
  121. cd $PKG
  122. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE