bowtie2.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116
  1. #!/bin/bash
  2. # Slackware build script for bowtie2
  3. # Copyright 2013-2016 Petar Petrov slackalaxy@gmail.com
  4. # Copyright 2018-2022 Rob van Nues sborg63@disroot.org
  5. #
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=bowtie2
  26. VERSION=${VERSION:-2.4.5}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "x86_64" ]; then
  48. SLKCFLAGS="-O2 -fPIC"
  49. LIBDIRSUFFIX="64"
  50. else
  51. printf "\n$ARCH is unsupported by $PRGNAM\n"
  52. exit 1
  53. fi
  54. set -e
  55. rm -rf $PKG
  56. mkdir -p $TMP $PKG $OUTPUT
  57. cd $TMP
  58. rm -rf $PRGNAM-$VERSION
  59. tar -xvzf $CWD/$PRGNAM-$VERSION.tar.gz
  60. cd $PRGNAM-$VERSION
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. #Use our FLAGS
  68. RELEASE_FLAGS+="$SLKCFLAGS" \
  69. make
  70. install -D -m755 $PRGNAM $PKG/usr/bin/$PRGNAM
  71. install -D -m755 $PRGNAM-align-l $PKG/usr/bin/$PRGNAM-align-l
  72. install -D -m755 $PRGNAM-build-l $PKG/usr/bin/$PRGNAM-build-l
  73. install -D -m755 $PRGNAM-align-s $PKG/usr/bin/$PRGNAM-align-s
  74. install -D -m755 $PRGNAM-build-s $PKG/usr/bin/$PRGNAM-build-s
  75. install -D -m755 $PRGNAM-build $PKG/usr/bin/$PRGNAM-build
  76. install -D -m755 $PRGNAM-inspect-l $PKG/usr/bin/$PRGNAM-inspect-l
  77. install -D -m755 $PRGNAM-inspect-s $PKG/usr/bin/$PRGNAM-inspect-s
  78. install -D -m755 $PRGNAM-inspect $PKG/usr/bin/$PRGNAM-inspect
  79. # Copy examples and scripts
  80. mkdir -p $PKG/usr/share/$PRGNAM
  81. cp -a \
  82. example scripts \
  83. $PKG/usr/share/$PRGNAM
  84. # Let's compress the reads and indexes
  85. gzip $PKG/usr/share/$PRGNAM/example/reads/*.fq
  86. gzip $PKG/usr/share/$PRGNAM/example/index/*.bt2
  87. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  88. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  89. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  90. cp -a \
  91. AUTHORS LICENSE MANUAL NEWS TUTORIAL BOWTIE2_VERSION doc \
  92. $PKG/usr/doc/$PRGNAM-$VERSION
  93. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cd $PKG
  97. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE