WordNet.SlackBuild 2.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102
  1. #!/bin/bash
  2. # Slackware build script for WordNet
  3. # Written by Michael Gabilondo <mgabilo{at}gmail{dot}com>
  4. # This work is in the public domain
  5. cd $(dirname $0) ; CWD=$(pwd)
  6. PRGNAM=WordNet
  7. VERSION=${VERSION:-3.0}
  8. BUILD=${BUILD:-2}
  9. TAG=${TAG:-_SBo}
  10. PKGTYPE=${PKGTYPE:-tgz}
  11. if [ -z "$ARCH" ]; then
  12. case "$( uname -m )" in
  13. i?86) ARCH=i486 ;;
  14. arm*) ARCH=arm ;;
  15. *) ARCH=$( uname -m ) ;;
  16. esac
  17. fi
  18. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  19. # the name of the created package would be, and then exit. This information
  20. # could be useful to other scripts.
  21. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  22. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  23. exit 0
  24. fi
  25. TMP=${TMP:-/tmp/SBo}
  26. PKG=$TMP/package-$PRGNAM
  27. OUTPUT=${OUTPUT:-/tmp}
  28. if [ "$ARCH" = "i486" ]; then
  29. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  30. LIBDIRSUFFIX=""
  31. elif [ "$ARCH" = "i686" ]; then
  32. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  33. LIBDIRSUFFIX=""
  34. elif [ "$ARCH" = "x86_64" ]; then
  35. SLKCFLAGS="-O2 -fPIC"
  36. LIBDIRSUFFIX="64"
  37. else
  38. SLKCFLAGS="-O2"
  39. LIBDIRSUFFIX=""
  40. fi
  41. set -e
  42. rm -rf $PKG
  43. mkdir -p $TMP $PKG $OUTPUT
  44. cd $TMP
  45. rm -rf $PRGNAM-$VERSION
  46. tar xvf $CWD/$PRGNAM-$VERSION.tar.bz2
  47. cd $PRGNAM-$VERSION
  48. chown -R root:root .
  49. find -L . \
  50. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  51. -exec chmod 755 {} \; -o \
  52. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  53. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  54. CFLAGS="$SLKCFLAGS" \
  55. CXXFLAGS="$SLKCFLAGS" \
  56. ./configure \
  57. --prefix=/usr \
  58. --libdir=/usr/lib${LIBDIRSUFFIX} \
  59. --exec-prefix=/usr \
  60. --sysconfdir=/etc \
  61. --localstatedir=/var \
  62. --mandir=/usr/man \
  63. --build=$ARCH-slackware-linux
  64. make CFLAGS="$CFLAGS -DUSE_INTERP_RESULT"
  65. make install DESTDIR=$PKG
  66. # Make sure WNHOME is set in the users' environments
  67. mkdir -p $PKG/etc/profile.d
  68. cat $CWD/profile.d/WordNet.sh > $PKG/etc/profile.d/WordNet.sh
  69. cat $CWD/profile.d/WordNet.csh > $PKG/etc/profile.d/WordNet.csh
  70. chmod 0755 $PKG/etc/profile.d/*
  71. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  72. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  73. ( cd $PKG/usr/man
  74. find . -type f -exec gzip -9 {} \;
  75. for i in $( find . -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  76. )
  77. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  78. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  79. ( cd $PKG/usr/doc ; mv html pdf ps $PRGNAM-$VERSION )
  80. mkdir -p $PKG/install
  81. cat $CWD/slack-desc > $PKG/install/slack-desc
  82. cd $PKG
  83. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE