STAR.SlackBuild 4.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128
  1. #!/bin/bash
  2. # Slackware build script for STAR
  3. # Copyright 2018-2022 Rob van Nues <sborg63@disroot.org>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=STAR
  24. VERSION=${VERSION:-2.7.10a}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. # This script is set for processors that support "Advanced Vector Extensions",
  29. # (AVX), included since 2008 in Intel processors (Sandy Bridge) and since 2011
  30. # in AMD cpus (Bulldozer). AVX is an implementation of "Single Instruction
  31. # stream-Multiple Data streams" (SIMD) to process vector type data.
  32. # If no AVX (`cat /proc/cpuinfo | grep 'avx'`) is present, specify the
  33. # available SIMD architecture (https://en.wikichip.org/wiki/x86/extensions),
  34. # e.g. with "Streaming SIMD Extensions" use 'sse', and uncomment the next line.
  35. #SIMD=${SIMD:-sse}; echo "Using ${SIMD} as SIMD"
  36. if [ -z "$ARCH" ]; then
  37. case "$( uname -m )" in
  38. i?86) ARCH=i586 ;;
  39. arm*) ARCH=arm ;;
  40. *) ARCH=$( uname -m ) ;;
  41. esac
  42. fi
  43. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  44. # the name of the created package would be, and then exit. This information
  45. # could be useful to other scripts.
  46. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  47. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  48. exit 0
  49. fi
  50. TMP=${TMP:-/tmp/SBo}
  51. PKG=$TMP/package-$PRGNAM
  52. OUTPUT=${OUTPUT:-/tmp}
  53. if [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC -fsigned-char"
  55. LIBDIRSUFFIX="64"
  56. else
  57. echo "Sorry, this program does not run/compile on your architecture ($ARCH)"
  58. exit 0
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $PRGNAM-$VERSION
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  66. cd $PRGNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. # for using shared, externally-installed htslib (as done on debian)
  74. #rm -rf htslib
  75. # from https://salsa.debian.org/med-team/rna-star/tree/master/debian/patches
  76. #patch < $CWD/donotuse_own_htslib.patch
  77. # but Alex Dobin, the developer of STAR does not advise this due to hacks he made in htslib
  78. # https://github.com/alexdobin/STAR/issues/351
  79. # https://github.com/alexdobin/STAR/issues/447
  80. #so let's forget about this for now
  81. #For processors that do not support AVX extensions, specify the target SIMD architecture
  82. #make STAR CXXFLAGS_SIMD=sse
  83. cd source
  84. if [ ! -z "${SIMD}" ]; then
  85. echo "make with CXXFLAG_SIMD=${SIMD}"
  86. make ${PRGNAM} CFLAGS="$SLKCFLAGS" CXXFLAGSextra="$SLKCFLAGS" CXXFLAGS_SIMD="$SIMD"
  87. else
  88. echo "default make"
  89. make ${PRGNAM} CFLAGS="$SLKCFLAGS" CXXFLAGSextra="$SLKCFLAGS"
  90. fi
  91. mkdir -p $PKG/usr/bin
  92. install -Dm755 $PRGNAM "$PKG/usr/bin/${PRGNAM}"
  93. #make clean
  94. #make ${PRGNAM}long CXXFLAGSextra="$CXXFLAGS"
  95. #install -Dm755 ${PRGNAM}long "$PKG/usr/bin/${PRGNAM}long"
  96. cd ..
  97. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  98. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  99. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  100. cp -a \
  101. source/parametersDefault doc/${PRGNAM}manual.pdf CHANGES.md LICENSE README.md RELEASEnotes.md \
  102. $PKG/usr/doc/$PRGNAM-$VERSION
  103. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  104. mkdir -p $PKG/install
  105. cat $CWD/slack-desc > $PKG/install/slack-desc
  106. cd $PKG
  107. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE