tty-prompt.SlackBuild 3.5 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125
  1. #!/bin/bash
  2. # Slackware build script for tty-prompt
  3. # Copyright 2022, Tonus, Paris
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=tty-prompt
  24. VERSION=${VERSION:-0.23.1}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. SRCNAM=tty-prompt
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  37. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  38. exit 0
  39. fi
  40. TMP=${TMP:-/tmp/SBo}
  41. PKG=$TMP/package-$PRGNAM
  42. OUTPUT=${OUTPUT:-/tmp}
  43. if [ "$ARCH" = "i586" ]; then
  44. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  45. LIBDIRSUFFIX=""
  46. elif [ "$ARCH" = "i686" ]; then
  47. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "x86_64" ]; then
  50. SLKCFLAGS="-O2 -fPIC"
  51. LIBDIRSUFFIX="64"
  52. else
  53. SLKCFLAGS="-O2"
  54. LIBDIRSUFFIX=""
  55. fi
  56. set -e
  57. rm -rf $PKG
  58. mkdir -p $TMP $PKG $OUTPUT
  59. cd $TMP
  60. DESTDIR=$( ruby -r rbconfig -e '
  61. include RbConfig
  62. printf("%s/%s/gems/%s\n",
  63. CONFIG["libdir"],
  64. CONFIG["RUBY_INSTALL_NAME"],
  65. CONFIG["ruby_version"]
  66. )
  67. ')
  68. gem specification $CWD/$SRCNAM-$VERSION.gem | \
  69. ruby -r yaml -r rbconfig -e '
  70. c = RbConfig::CONFIG
  71. path = sprintf("%s/%s/gems/%s",
  72. c["libdir"],
  73. c["RUBY_INSTALL_NAME"],
  74. c["ruby_version"])
  75. sys_gemspecs = Dir.glob(path + "/specifications/**/*.gemspec").map {|g| gs = Gem::Specification.load(g); gs.name }
  76. obj = Gem::Specification.from_yaml($stdin)
  77. obj.dependencies.each {|dep|
  78. if not(dep.type == :runtime)
  79. next
  80. end
  81. if not(sys_gemspecs.include?(dep.name))
  82. $stderr.write("WARNING: #{dep.name} gem not found\n")
  83. sleep 0.5
  84. end
  85. }'
  86. gem install \
  87. --local \
  88. --no-update-sources \
  89. --ignore-dependencies \
  90. --backtrace \
  91. --install-dir $PKG/$DESTDIR \
  92. --bindir $PKG/usr/bin \
  93. $CWD/$SRCNAM-$VERSION.gem
  94. # Strip binaries and libraries.
  95. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  96. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  97. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  98. tar -x -O --file=$CWD/$SRCNAM-$VERSION.gem data.tar.gz \
  99. | tar -xz -C $PKG/usr/doc/$PRGNAM-$VERSION --file=-
  100. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  101. chown -R root:root $PKG/usr/doc/$PRGNAM-$VERSION
  102. mkdir -p $PKG/install
  103. cat $CWD/slack-desc > $PKG/install/slack-desc
  104. cd $PKG
  105. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE