libreoffice-helppack.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115
  1. #!/bin/bash
  2. # Slackware build script for LibreOffice Help Packs
  3. # Copyright 2013-2014 Niels Horn, Rio de Janeiro, RJ, Brazil
  4. # Copyright 2014-2021 Willy Sudiarto Raharjo <willysr@slackbuilds.org>
  5. # All rights reserved.
  6. #
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. #
  10. # 1. Redistributions of this script must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  14. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  15. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  16. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  17. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  18. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  19. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  21. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  22. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=libreoffice-helppack
  25. VERSION=${VERSION:-"7.3.2"}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. LOLANG=${LOLANG:-en-US}
  30. PKG_LANG=${LOLANG//-/_}
  31. # I'll leave this line here, as I always have to change it with every release
  32. SRCVERSION=$VERSION
  33. SRCSHORT=$(echo $VERSION | cut -f1-2 -d.)
  34. if [ -z "$ARCH" ]; then
  35. case "$( uname -m )" in
  36. i?86) ARCH=i586 ;;
  37. arm*) ARCH=arm ;;
  38. *) ARCH=$( uname -m ) ;;
  39. esac
  40. fi
  41. # Change source package name
  42. if [ "$ARCH" = "x86_64" ]; then
  43. SRCARCH="x86-64"
  44. PKGARCH="$ARCH"
  45. LIBDIRSUFFIX=64
  46. elif [ "$ARCH" = "arm" ]; then
  47. printf "\n$ARCH is unsupported for LibreOffice...\n\n"
  48. exit 1
  49. else
  50. SRCARCH="x86"
  51. PKGARCH="i586"
  52. LIBDIRSUFFIX=""
  53. fi
  54. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  55. # the name of the created package would be, and then exit. This information
  56. # could be useful to other scripts.
  57. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  58. echo "${PRGNAM}_${PKG_LANG}-$VERSION-$PKGARCH-$BUILD$TAG.$PKGTYPE"
  59. exit 0
  60. fi
  61. TMP=${TMP:-/tmp/SBo}
  62. PKG=$TMP/package-$PRGNAM
  63. OUTPUT=${OUTPUT:-/tmp}
  64. set -e
  65. # Concatenate all parts to get the full name of the tarball
  66. TARBALL="LibreOffice_${SRCVERSION}_Linux_${SRCARCH}_rpm_helppack_${LOLANG}.tar.gz"
  67. if [ ! -r $TARBALL ]; then
  68. echo "$TARBALL not found"
  69. exit 1
  70. fi
  71. # Get "base" directory of tarball
  72. SOURCEDIR=$(tar tzf $CWD/$TARBALL 2>/dev/null | head -n 1 | tr -d \/)
  73. rm -rf $PKG
  74. mkdir -p $TMP $PKG $OUTPUT
  75. rm -rf $TMP/$SOURCEDIR
  76. tar xvf $CWD/$TARBALL -C $TMP
  77. cd $TMP/$SOURCEDIR/RPMS/
  78. for FILE in *.rpm ; do rpm2cpio < $FILE | cpio -imdv ; done
  79. mv opt $PKG
  80. cd $PKG
  81. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  82. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  83. mkdir -p $PKG/install
  84. cat $CWD/slack-desc > $PKG/install/slack-desc
  85. # Fix ownership and permissions and make the package
  86. chown -R root:root .
  87. find . -type d -exec chmod 755 {} \;
  88. find -L . \
  89. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  90. -o -perm 511 \) -exec chmod 755 {} \; -o \
  91. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  92. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  93. /sbin/makepkg -l y -c n $OUTPUT/${PRGNAM}_${PKG_LANG}-${VERSION}-$PKGARCH-$BUILD$TAG.$PKGTYPE