JabRef.SlackBuild 3.0 KB

12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485
  1. #!/bin/bash
  2. # Slackware build script for JabRef
  3. # Copyright 2008-2010, Antonio Hernández Blas <hba.nihilismus@gmail.com>
  4. # Update by: Andre Barboza <bmg.andre@gmail.com>
  5. # Copyright 2020, David O'Shaughnessy
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=JabRef
  26. VERSION=${VERSION:-5.5}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. DEBBUILD=${DEBBUILD:-1}
  31. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  32. # the name of the created package would be, and then exit. This information
  33. # could be useful to other scripts.
  34. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  35. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  36. exit 0
  37. fi
  38. TMP=${TMP:-/tmp/SBo}
  39. PKG=$TMP/package-$PRGNAM
  40. OUTPUT=${OUTPUT:-/tmp}
  41. ARCH=${ARCH:-noarch}
  42. DEBARCH=amd64
  43. set -e
  44. rm -rf "$PKG"
  45. mkdir -p "$TMP" "$PKG" "$OUTPUT"
  46. cd "$PKG"
  47. ar p "$CWD"/${PRGNAM,,}_"$VERSION"-"$DEBBUILD"_"$DEBARCH".deb data.tar.xz | tar xJv
  48. # permissions
  49. chown -R root:root .
  50. find -L . \
  51. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  52. -o -perm 511 \) -exec chmod 755 {} \; -o \
  53. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  54. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  55. find "$PKG" -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  56. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  57. # create a symlink for program
  58. mkdir -p "$PKG"/usr/bin
  59. ln -s /opt/${PRGNAM,,}/bin/$PRGNAM "$PKG"/usr/bin/$PRGNAM
  60. # desktop and icon
  61. install -D -m 0644 opt/${PRGNAM,,}/lib/${PRGNAM,,}-$PRGNAM.desktop -t "$PKG"/usr/share/applications
  62. install -D -m 0644 opt/${PRGNAM,,}/lib/$PRGNAM.png -t "$PKG"/usr/share/pixmaps
  63. # docs
  64. install -D -m 0644 opt/${PRGNAM,,}/share/doc/* "$CWD"/$PRGNAM.SlackBuild -t "$PKG"/usr/doc/$PRGNAM-"$VERSION"
  65. mkdir -p $PKG/install
  66. cat $CWD/slack-desc > $PKG/install/slack-desc
  67. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  68. cd $PKG
  69. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE