makemkv.SlackBuild 4.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153
  1. #!/bin/bash
  2. # Slackware build script for MakeMKV
  3. # Copyright 2019 T3slider <t3slider@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=makemkv
  24. VERSION=${VERSION:-1.14.4}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. ARCHDIR=i386
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. ARCHDIR=i386
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. # -fPIC was causing segfaults...
  55. SLKCFLAGS="-O2"
  56. ARCHDIR=amd64
  57. LIBDIRSUFFIX="64"
  58. else
  59. SLKCFLAGS="-O2"
  60. ARCHDIR=i386
  61. LIBDIRSUFFIX=""
  62. fi
  63. # Note: MakeMKV now includes a mips32 binary, but since there is no official
  64. # MIPS Slackware port I'm ignoring it unless someone complains. Still no ARM
  65. # version.
  66. # Spoof libaacs and libbdplus? (This will override real libaacs.so.0 and
  67. # libbdplus.so.0 upon package installation if they are present! If you want
  68. # to spoof this, you should ensure those packages are not installed!)
  69. FAKELIBS=${FAKELIBS:-no}
  70. set -e
  71. rm -rf $PKG
  72. mkdir -p $TMP $PKG $OUTPUT
  73. cd $TMP
  74. # Build the open source component first...
  75. rm -rf ${PRGNAM}-oss-${VERSION}
  76. tar xvf $CWD/${PRGNAM}-oss-${VERSION}.tar.gz
  77. cd ${PRGNAM}-oss-${VERSION}
  78. chown -R root:root .
  79. find -L . \
  80. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  81. -o -perm 511 \) -exec chmod 755 {} \; -o \
  82. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  83. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  84. CFLAGS="$SLKCFLAGS" \
  85. CXXFLAGS="$SLKCFLAGS" \
  86. ./configure \
  87. --prefix=/usr \
  88. --libdir=/usr/lib${LIBDIRSUFFIX} \
  89. --sysconfdir=/etc \
  90. --localstatedir=/var \
  91. --mandir=/usr/man \
  92. --docdir=/usr/doc/$PRGNAM-$VERSION \
  93. --build=$ARCH-slackware-linux
  94. make
  95. make install DESTDIR=$PKG
  96. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  97. cp -a License.txt $PKG/usr/doc/$PRGNAM-$VERSION
  98. # Now extract/copy the closed source component...
  99. cd $TMP
  100. rm -rf ${PRGNAM}-bin-${VERSION}
  101. tar xvf $CWD/${PRGNAM}-bin-${VERSION}.tar.gz
  102. cd ${PRGNAM}-bin-${VERSION}
  103. chown -R root:root .
  104. find -L . \
  105. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  106. -o -perm 511 \) -exec chmod 755 {} \; -o \
  107. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  108. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  109. # The makefile now supports DESTDIR so it's easier to use it. This is just
  110. # removing the mandatory interactive EULA agreement which might confuse
  111. # SlackBuild users (check the README which tells you to read the EULA anyway...)
  112. sed -i "s/^\(install:\).*/\1/" Makefile
  113. # We will not leave CPU detection up to the makefile here just in case...
  114. make install ARCH=$ARCHDIR ARCH_OK=1 DESTDIR=$PKG
  115. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  116. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  117. cp -a src/eula_en_linux.txt $PKG/usr/doc/$PRGNAM-$VERSION
  118. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  119. cat $CWD/README.issues > $PKG/usr/doc/$PRGNAM-$VERSION/README.issues
  120. if [ "$FAKELIBS" != "no" ]; then
  121. cd $PKG/usr/lib${LIBDIRSUFFIX}
  122. ln -s libmmbd.so.0 libaacs.so.0
  123. ln -s libmmbd.so.0 libbdplus.so.0
  124. fi
  125. mkdir -p $PKG/install
  126. cat $CWD/slack-desc > $PKG/install/slack-desc
  127. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  128. cd $PKG
  129. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE