12345678910111213141516171819202122232425262728293031323334353637383940414243444546474849505152535455565758596061626364656667686970717273747576777879808182838485 |
- #!/bin/bash
- # Slackware build script for jsmin
- # Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
- # 2017 | Dhaby Xiloj | slack.dhabyx@gmail.com
- # This program is free software: you can redistribute it and/or modify
- # it under the terms of the GNU General Public License as published by
- # the Free Software Foundation; either version 2 of the License, or
- # (at your option) any later version, with the following exception:
- # the text of the GPL license may be omitted.
- # This program is distributed in the hope that it will be useful, but
- # without any warranty; without even the implied warranty of
- # merchantability or fitness for a particular purpose. Compiling,
- # interpreting, executing or merely reading the text of the program
- # may result in lapses of consciousness and/or very being, up to and
- # including the end of all existence and the Universe as we know it.
- # See the GNU General Public License for more details.
- # You may have received a copy of the GNU General Public License along
- # with this program (most likely, a file named COPYING). If not, see
- # <https://www.gnu.org/licenses/>.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=jsmin
- SRCNAM=JSMin
- VERSION=${VERSION:-20130329}
- SRCVERSION=${SRCVERSION:-1bf6ce5f74a9f8752ac7f5d115b8d7ccb31cfe1b}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i486 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-$SRCVERSION
- tar xvf $CWD/$SRCNAM-$SRCVERSION.tar.gz || tar xvf $CWD/$SRCVERSION.tar.gz
- cd $SRCNAM-$SRCVERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- mkdir -p $PKG/usr/bin/
- gcc $PRGNAM.c -o $PKG/usr/bin/$PRGNAM
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|