geany-plugins.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120
  1. #!/bin/bash
  2. # Slackware build script for Geany Plugins
  3. # Ryan P.C. McQuen | Everett, WA | ryanpcmcquen@member.fsf.org
  4. # Copyright 2010-2013 James Geboski <jgeboski@gmail.com>
  5. # Copyright 2013-2014 Michiel van Wessem, Leicester, United Kingdom.
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. # 20220308 bkw: Modified by SlackBuilds.org, BUILD=3:
  25. # - disable the 2 plugins that require libgit2. they won't build
  26. # with our libgit2.
  27. # - get rid of 0-byte placeholders in doc dir.
  28. cd $(dirname $0) ; CWD=$(pwd)
  29. PRGNAM=geany-plugins
  30. VERSION=${VERSION:-1.36.0}
  31. BUILD=${BUILD:-3}
  32. TAG=${TAG:-_SBo}
  33. PKGTYPE=${PKGTYPE:-tgz}
  34. if [ -z "$ARCH" ]; then
  35. case "$( uname -m )" in
  36. i?86) ARCH=i586 ;;
  37. arm*) ARCH=arm ;;
  38. *) ARCH=$( uname -m ) ;;
  39. esac
  40. fi
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. if [ "$ARCH" = "i586" ]; then
  49. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "i686" ]; then
  52. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  53. LIBDIRSUFFIX=""
  54. elif [ "$ARCH" = "x86_64" ]; then
  55. SLKCFLAGS="-O2 -fPIC"
  56. LIBDIRSUFFIX="64"
  57. else
  58. SLKCFLAGS="-O2"
  59. LIBDIRSUFFIX=""
  60. fi
  61. set -e
  62. rm -rf $PKG
  63. mkdir -p $TMP $PKG $OUTPUT
  64. cd $TMP
  65. rm -rf $PRGNAM-$VERSION
  66. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  67. cd $PRGNAM-$VERSION
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  74. CFLAGS="$SLKCFLAGS" \
  75. CXXFLAGS="$SLKCFLAGS" \
  76. ./autogen.sh \
  77. --prefix=/usr \
  78. --libdir=/usr/lib${LIBDIRSUFFIX} \
  79. --sysconfdir=/etc \
  80. --localstatedir=/var \
  81. --mandir=/usr/man \
  82. --docdir=/usr/doc/$PRGNAM-$VERSION \
  83. --disable-static \
  84. --disable-workbench \
  85. --disable-gitchangebar \
  86. --build=$ARCH-slackware-linux
  87. make
  88. make install-strip DESTDIR=$PKG
  89. PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
  90. mkdir -p $PKGDOC
  91. cp -a HACKING MAINTAINERS NEWS README $PKGDOC
  92. cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
  93. # 20220308 bkw: bunch of placeholder NEWS and ChangeLog files:
  94. find $PKGDOC -type f -a -empty -delete
  95. rm -f $PKG/usr/lib*/*.la
  96. mkdir -p $PKG/install
  97. cat $CWD/slack-desc > $PKG/install/slack-desc
  98. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  99. cd $PKG
  100. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE