perl-MIME-tools.SlackBuild 3.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. #!/bin/bash
  2. # Slackware Package Build Script for perl modules: MIME-tools
  3. # Home Page https://metacpan.org/release/MIME-tools
  4. # Copyright (c) 2009-2015, Nishant Limbachia, Hoffman Estates, IL, USA
  5. # (nishant _AT_ mnspace _DOT_ net)
  6. # All rights reserved.
  7. # Redistribution and use of this script, with or without modification, is
  8. # permitted provided that the following conditions are met:
  9. # 1. Redistributions of script must retain the above copyright notice,
  10. # this list of conditions and the following disclaimer.
  11. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  12. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  13. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  14. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT OWNER OR
  15. # CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL,
  16. # EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR
  18. # PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF
  19. # LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
  20. # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  21. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. #
  23. # Modified by the SlackBuilds.org project.
  24. SRCNAM="MIME-tools"
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM="perl-MIME-tools"
  27. VERSION=${VERSION:-5.506}
  28. BUILD=${BUILD:-1}
  29. TAG=${TAG:-_SBo}
  30. PKGTYPE=${PKGTYPE:-tgz}
  31. if [ -z "$ARCH" ]; then
  32. case "$( uname -m )" in
  33. i?86) ARCH=i486 ;;
  34. arm*) ARCH=arm ;;
  35. *) ARCH=$( uname -m ) ;;
  36. esac
  37. fi
  38. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  39. # the name of the created package would be, and then exit. This information
  40. # could be useful to other scripts.
  41. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  42. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  43. exit 0
  44. fi
  45. TMP=${TMP:-/tmp/SBo}
  46. PKG=$TMP/package-$PRGNAM
  47. OUTPUT=${OUTPUT:-/tmp}
  48. set -e
  49. DOCS="COPYING ChangeLog README* INSTALLING"
  50. if [ "$ARCH" = "i486" ]; then
  51. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "i686" ]; then
  54. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  55. LIBDIRSUFFIX=""
  56. elif [ "$ARCH" = "x86_64" ]; then
  57. SLKCFLAGS="-O2 -fPIC"
  58. LIBDIRSUFFIX="64"
  59. else
  60. SLKCFLAGS="-O2"
  61. LIBDIRSUFFIX=""
  62. fi
  63. rm -fr $TMP/$SRCNAM-$VERSION $PKG
  64. mkdir -p $TMP $PKG $OUTPUT
  65. cd $TMP
  66. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  67. cd $TMP/$SRCNAM-$VERSION
  68. chown -R root.root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  71. -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
  73. -exec chmod 644 {} \;
  74. CFLAGS="$SLKCFLAGS" \
  75. perl Makefile.PL PREFIX=/usr INSTALLDIRS=vendor INSTALLVENDORMAN3DIR=/usr/man/man3
  76. make
  77. make install DESTDIR=$PKG
  78. ### putting essential docs
  79. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  80. cp -a $DOCS $PKG/usr/doc/$PRGNAM-$VERSION
  81. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  82. # Remove perlocal.pod and .packlist from $PKG
  83. find $PKG -name "perllocal.pod" -o -name ".packlist" -o -name "*.bs" | xargs rm -f
  84. # Remove empty directories
  85. find $PKG -depth -type d -empty -exec rm -rf {} \;
  86. ### strip binaries
  87. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  88. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  89. find $PKG/usr/man -type f -exec gzip -9 {} \;
  90. for i in $(find $PKG/usr/man -type l) ; do ln -s $(readlink $i).gz $i.gz ; rm $i ; done
  91. mkdir -p $PKG/install
  92. cat $CWD/slack-desc > $PKG/install/slack-desc
  93. cd $PKG
  94. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE