123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121 |
- #!/bin/bash
- # Slackware build script for perl-GD
- # Written by B. Watson (yalhcru@gmail.com)
- # Licensed under the WTFPL. See http://www.wtfpl.net/txt/copying/ for details.
- # 20211012 bkw: BUILD=2. Fix -current build, by commenting out
- # 'make test'. This is because of the (fairly) recent gd-2.3.3
- # update in -current. libgd upstream changed the default for the
- # (undocumented) --enable-gd-formats option to 'no' in 2.3.3, and
- # the perl-GD tests include .gd and .gd2 images. Sent a note to PV,
- # hopefully he rebuilds gd with re-added support for .gd/.gd2 images.
- # 20200929 bkw: update for v2.73
- # 20191201 bkw: update for v2.71
- # 20180829 bkw: update for v2.69
- # 20180611 bkw: update for v2.68
- # 20180228 bkw:
- # - fix build on 32-bit. Thanks to idlemoor for the bug report.
- # - add FASTCGI option
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=perl-GD
- VERSION=${VERSION:-2.73}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- SRCNAM="GD"
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- # You might notice this in the build log:
- # ** WARNING: found gd.h header file in /usr/X11R6/include/gd.h
- # This isn't a real issue, since on Slackware /usr/X11R6/include
- # is just a symlink to /usr/include.
- if [ "${FASTCGI:-no}" = "yes" ]; then
- FCGIOPT="--fcgi"
- WITH="with"
- else
- FCGIOPT=""
- WITH="without"
- fi
- perl Makefile.PL \
- --lib_gd_path /usr \
- $FCGIOPT \
- PREFIX=/usr \
- INSTALLDIRS=vendor \
- INSTALLVENDORMAN3DIR=/usr/man/man3 \
- INSTALLVENDORMAN1DIR=/usr/man/man1
- make
- # make test # commented out until further notice!
- make install DESTDIR=$PKG
- find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
- find $PKG -name perllocal.pod \
- -o -name ".packlist" \
- -o -name "*.bs" \
- | xargs rm -f
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a README* ChangeLog LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- sed "s,@WITH@,$WITH," $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|