texworks.SlackBuild 3.4 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117
  1. #!/bin/bash
  2. # Slackware build script for TeXworks
  3. # Written by digwtx (wtx358@qq.com)
  4. # Updated by Willy Sudiarto Raharjo
  5. # Copyright 2016 - 2022 Johannes Schoepfer, Germany
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=texworks
  26. VERSION=${VERSION:-0.6.7}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  38. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  39. exit 0
  40. fi
  41. TMP=${TMP:-/tmp/SBo}
  42. PKG=$TMP/package-$PRGNAM
  43. OUTPUT=${OUTPUT:-/tmp}
  44. if [ "$ARCH" = "i586" ]; then
  45. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  46. LIBDIRSUFFIX=""
  47. elif [ "$ARCH" = "i686" ]; then
  48. SLKCFLAGS="-O2 -march=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "x86_64" ]; then
  51. SLKCFLAGS="-O2 -fPIC"
  52. LIBDIRSUFFIX="64"
  53. else
  54. SLKCFLAGS="-O2"
  55. LIBDIRSUFFIX=""
  56. fi
  57. set -e
  58. rm -rf $PKG
  59. mkdir -p $TMP $PKG $OUTPUT
  60. cd $TMP
  61. rm -rf $PRGNAM-release-$VERSION
  62. tar xvf $CWD/$PRGNAM-release-$VERSION.tar.gz
  63. cd $PRGNAM-release-$VERSION
  64. chown -R root:root .
  65. find -L . \
  66. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  67. -o -perm 511 \) -exec chmod 755 {} \; -o \
  68. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  69. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  70. mkdir build
  71. cd build
  72. cmake \
  73. -DCMAKE_C_FLAGS:STRING="$SLKCFLAGS" \
  74. -DCMAKE_CXX_FLAGS:STRING="$SLKCFLAGS" \
  75. -DCMAKE_INSTALL_PREFIX=/usr \
  76. -DTeXworks_PLUGIN_DIR="/usr/lib$LIBDIRSUFFIX/texworks" \
  77. -DTW_BUILD_ID='slackbuilds.org' \
  78. -DWITH_PYTHON='ON' \
  79. -DPYTHON_EXECUTABLE:FILEPATH=/usr/bin/python3 \
  80. -DBUILD_SHARED_LIBS=ON \
  81. -DCMAKE_BUILD_TYPE=Release \
  82. ..
  83. make
  84. make install DESTDIR=$PKG
  85. cd ..
  86. mkdir -p $PKG/usr/man/man1
  87. cat $PKG/usr/share/man/man1/texworks.1 | gzip > $PKG/usr/man/man1/texworks.1.gz
  88. rm -rf $PKG/usr/share/man
  89. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  90. cp $PKG/usr/share/doc/texworks/{COPYING,NEWS,README.md} \
  91. $PKG/usr/doc/$PRGNAM-$VERSION
  92. rm -rf $PKG/usr/share/doc
  93. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  94. find $PKG | xargs file | grep -e "executable" -e "shared object" \
  95. | grep ELF | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  96. mkdir -p $PKG/install
  97. cat $CWD/slack-desc > $PKG/install/slack-desc
  98. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  99. cd $PKG
  100. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE