smoffice2021.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. #!/bin/bash
  2. # Slackware build script for smoffice2021
  3. # Based on the smoffice2018 SlackBuild by Alexander Verbovetsky
  4. # Based on the Arch Linux PKGBUILD.
  5. # Copyright 2020, Donald Cooley, South Haven, Indiana, USA
  6. # All rights reserved.
  7. #
  8. # Redistribution and use of this script, with or without modification, is
  9. # permitted provided that the following conditions are met:
  10. #
  11. # 1. Redistributions of this script must retain the above copyright
  12. # notice, this list of conditions and the following disclaimer.
  13. #
  14. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  15. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  16. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  17. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  19. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  20. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  21. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  22. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  23. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=smoffice2021
  26. VERSION=${VERSION:-2021_1024}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # Abort build if architecture is not 64-bit.
  38. if [ "$ARCH" != "x86_64" ]; then
  39. echo "$ARCH is not supported."
  40. fi
  41. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  42. # the name of the created package would be, and then exit. This information
  43. # could be useful to other scripts.
  44. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  45. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  46. exit 0
  47. fi
  48. TMP=${TMP:-/tmp/SBo}
  49. PKG=$TMP/package-$PRGNAM
  50. OUTPUT=${OUTPUT:-/tmp}
  51. set -e
  52. rm -rf $PKG
  53. mkdir -p $TMP $PKG/opt/smoffice2021 $OUTPUT
  54. cd $TMP
  55. tar xvf $CWD/softmaker-office-${VERSION//_/-}-amd64.tgz
  56. tar xvf office2021.tar.lzma -C $PKG/opt/smoffice2021
  57. cd $PKG
  58. mkdir -p usr/bin
  59. install -m 0755 -o root -g root $CWD/planmaker21 usr/bin
  60. install -m 0755 -o root -g root $CWD/presentations21 usr/bin
  61. install -m 0755 -o root -g root $CWD/textmaker21 usr/bin
  62. for s in 16 24 32 48 64 128 256 512 1024; do
  63. mkdir -p usr/share/icons/hicolor/${s}x${s}/apps
  64. for a in pml prl tml; do
  65. cp -a opt/smoffice2021/icons/${a}_${s}.png \
  66. usr/share/icons/hicolor/${s}x${s}/apps/application-x-${a}21.png
  67. done
  68. done
  69. for s in 16 24 32 48 64 128 256 512 1024; do
  70. mkdir -p usr/share/icons/hicolor/${s}x${s}/mimetypes
  71. for a in pmd pmd_mso pmd_oth prd prd_mso prd_oth tmd tmd_mso tmd_oth; do
  72. cp -a opt/smoffice2021/icons/${a}_${s}.png \
  73. usr/share/icons/hicolor/${s}x${s}/mimetypes/application-x-${a}.png
  74. done
  75. done
  76. mkdir -p usr/share/applications
  77. cp -a $CWD/planmaker-2021.desktop usr/share/applications/
  78. cp -a $CWD/presentations-2021.desktop usr/share/applications/
  79. cp -a $CWD/textmaker-2021.desktop usr/share/applications/
  80. mkdir -p usr/share/mime/packages/
  81. cp -a opt/smoffice2021/mime/softmaker-office-2021.xml \
  82. usr/share/mime/packages/
  83. chown -R root:root .
  84. find -L . \
  85. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  86. -o -perm 511 \) -exec chmod 755 {} \; -o \
  87. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  88. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  89. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  90. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  91. mkdir -p usr/doc/$PRGNAM-$VERSION
  92. mv opt/smoffice2021/*.pdf opt/smoffice2021/mime/copyright \
  93. usr/doc/$PRGNAM-$VERSION
  94. cat $CWD/$PRGNAM.SlackBuild > usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  95. mkdir -p install
  96. cat $CWD/slack-desc > install/slack-desc
  97. cat $CWD/doinst.sh > install/doinst.sh
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE