1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495969798 |
- #!/bin/bash
- # Slackware build script for moneydance
- # Copyright 2008-2021 Robby Workman, Tuscaloosa, AL, USA
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=moneydance
- VERSION=${VERSION:-2021.1.3069}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "x86_64" ]; then
- MDARCH=amd64
- else
- printf "$ARCH is not supported.\n"; exit 1
- fi
- set -e
- rm -rf $TMP/$PRGNAM $PKG
- mkdir -p $TMP/$PRGNAM $PKG
- cd $TMP/$PRGNAM
- ar -x $CWD/${PRGNAM}_linux_amd64.deb
- tar xvf data.tar.bz2 -C $PKG
- rm -f $PKG/opt/Moneydance/create_desktop_file.sh
- mkdir -p $PKG/usr/bin
- ln -s /opt/Moneydance/Moneydance $PKG/usr/bin/moneydance
- ln -s /opt/Moneydance/Moneydance $PKG/usr/bin/Moneydance
- mkdir -p $PKG/usr/share/applications
- cat $CWD/moneydance.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
- rm -f $PKG/opt/Moneydance/resources/moneydance.desktop
- mkdir -p $PKG/usr/share/pixmaps
- ln -s /opt/Moneydance/resources/moneydance_icon32.png \
- $PKG/usr/share/pixmaps/$PRGNAM.png
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- mv $PKG/opt/Moneydance/README.md $PKG/usr/doc/$PRGNAM-$VERSION
- ln -s /opt/Moneydance/resources/license.txt \
- $PKG/usr/doc/$PRGNAM-$VERSION/license.txt
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
- -o -perm 511 \) -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
- -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
- /sbin/makepkg -c n -l y $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|