123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117 |
- #!/bin/bash
- # Slackware build script for hunspell-es
- # Copyright 2017 Dhaby Xiloj <slack.dhabyx@gmail.com>
- # Copyright 2014-2017 Pablo Santamaria (pablosantamaria@gmail.com)
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Based on the Arch PKGBUILD
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=hunspell-es
- VERSION=${VERSION:-2.2}
- BUILD=${BUILD:-1}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- ARCH="noarch"
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- # Getting all localizations available
- LOCALIZATIONS=*.oxt
- LOCALIZATIONS=$(echo $LOCALIZATIONS | sed -e 's/es_ANY.oxt//g' | sed -e 's/.oxt//g')
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $PRGNAM-$VERSION
- mkdir -p $PRGNAM-$VERSION
- cd $PRGNAM-$VERSION
- for file in $CWD/*.oxt ; do
- LANG=en_US.utf8 bsdtar -xf $file
- done
- # Putting everything in proper place
- install -dm755 $PKG/usr/share/hunspell
- install -m644 es_*.dic es_*.aff $PKG/usr/share/hunspell
- install -Dm644 hyph_es_ANY.dic $PKG/usr/share/hyphen/hyph_es_ANY.dic
- install -dm755 $PKG/usr/share/mythes
- install -m644 th_es_ES_v2.* $PKG/usr/share/mythes
- # Symlinks for ditcs
- install -dm755 $PKG/usr/share/myspell/dicts
- pushd $PKG/usr/share/myspell/dicts
- for file in $PKG/usr/share/hunspell/*; do
- ln -sv ../../hunspell/$(basename $file) .
- done
- popd
- # Hyphenation symlinks
- pushd $PKG/usr/share/hyphen/
- echo $LOCALIZATIONS
- for lang in $LOCALIZATIONS; do
- ln -sv hyph_es_ANY.dic hyph_${lang}.dic
- done
- popd
- # Thesaurus symlinks
- pushd $PKG/usr/share/mythes/
- for lang in $(echo $LOCALIZATIONS | sed -e 's/es_ES//g'); do
- ln -sv th_es_ES_v2.idx th_${lang}_v2.idx
- ln -sv th_es_ES_v2.dat th_${lang}_v2.dat
- done
- popd
- # myspell symlinks
- install -dm755 $PKG/usr/share/myspell/dicts
- pushd $PKG/usr/share/myspell/dicts
- for file in $PKG/usr/share/hyphen/*; do
- ln -sv ../../hyphen/$(basename $file) .
- done
- for file in $PKG/usr/share/mythes/*; do
- ln -sv ../../mythes/$(basename $file) .
- done
- popd
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- install -m644 README* COPYING* $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|