freemind.SlackBuild 2.9 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283
  1. #!/bin/bash
  2. # Slackware build script for freemind
  3. # Copyright 2009,2011,2015 BrunoRusso, Sao Paulo, Brazil
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ''AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Modified by Robby Workman to include some things that were done in the old
  23. # build for 14.1 (that one had apparently been abandoned and thus Bruno
  24. # rewrote it, unaware that one had already existed).
  25. cd $(dirname $0) ; CWD=$(pwd)
  26. PRGNAM=freemind
  27. VERSION=${VERSION:-1.0.1}
  28. ARCH=noarch
  29. BUILD=${BUILD:-1}
  30. TAG=${TAG:-_SBo}
  31. PKGTYPE=${PKGTYPE:-tgz}
  32. #SRC_VERSION=$(echo $VERSION | tr . _)
  33. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  34. # the name of the created package would be, and then exit. This information
  35. # could be useful to other scripts.
  36. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  37. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  38. exit 0
  39. fi
  40. TMP=${TMP:-/tmp/SBo}
  41. PKG=$TMP/package-$PRGNAM
  42. OUTPUT=${OUTPUT:-/tmp}
  43. set -e
  44. rm -rf $PKG $TMP/$PRGNAM
  45. mkdir -p $TMP $PKG/opt/$PRGNAM $OUTPUT
  46. cd $TMP
  47. unzip $CWD/freemind-bin-max-$VERSION.zip -d $PKG/opt/$PRGNAM
  48. # Make a wrapper in /usr/bin
  49. mkdir -p $PKG/usr/bin
  50. cat $CWD/freemind.sh > $PKG/usr/bin/freemind
  51. chmod 0755 $PKG/opt/freemind $PKG/opt/freemind/*.sh $PKG/usr/bin/freemind
  52. # Install desktop file, icon, and mimetype files
  53. mkdir -p $PKG/usr/share/{applications,pixmaps,mime/packages}
  54. cat $CWD/$PRGNAM.desktop > $PKG/usr/share/applications/$PRGNAM.desktop
  55. cat $CWD/freemind.png > $PKG/usr/share/pixmaps/$PRGNAM.png
  56. cat $CWD/$PRGNAM.xml > $PKG/usr/share/mime/packages/$PRGNAM.xml
  57. mkdir -p $PKG/install
  58. cat $CWD/slack-desc > $PKG/install/slack-desc
  59. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  60. cd $PKG
  61. chown -R root:root .
  62. find -L . \
  63. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  64. -o -perm 511 \) -exec chmod 755 {} \; -o \
  65. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  66. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  67. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE