bibtex2html.SlackBuild 3.8 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122
  1. #!/bin/bash
  2. # Slackware build script for bibtex2html
  3. # Copyright 2018 Pedro R.M. Júnior, Campinas, SP, Brazil
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification,
  7. # is permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR
  13. # IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
  14. # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE
  15. # ARE DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
  16. # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL
  17. # DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
  18. # GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS
  19. # INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  20. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING
  21. # NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
  22. # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=bibtex2html
  25. VERSION=${VERSION:-1.99}
  26. BUILD=${BUILD:-1}
  27. TAG=${TAG:-_SBo}
  28. PKGTYPE=${PKGTYPE:-tgz}
  29. if [ -z "$ARCH" ]; then
  30. case "$( uname -m )" in
  31. i?86) ARCH=i586 ;;
  32. arm*) ARCH=arm ;;
  33. *) ARCH=$( uname -m ) ;;
  34. esac
  35. fi
  36. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  37. # the name of the created package would be, and then exit. This information
  38. # could be useful to other scripts.
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$VERSION
  64. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  65. cd $PRGNAM-$VERSION
  66. chown -R root:root .
  67. find -L . \
  68. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  69. -o -perm 511 \) -exec chmod 755 {} \; -o \
  70. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  71. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  72. CFLAGS="$SLKCFLAGS" \
  73. CXXFLAGS="$SLKCFLAGS" \
  74. ./configure \
  75. --prefix=/usr \
  76. --mandir=/usr/man \
  77. $([ "${DISABLE_DOC:=no}" = "yes" ] && echo --disable-doc) \
  78. --build=$ARCH-slackware-linux
  79. # For some reason, the generated Makefile have a hard coded `MANDIR`,
  80. # so we need to patch this to be based in ${prefix}, as for `BINDIR`.
  81. sed -i 's/MANDIR = \/usr\/man/MANDIR = ${prefix}\/man/' Makefile
  82. ###sbolint off
  83. # Compile the application and install it into the $PKG directory. As
  84. # the Makefile does not support `DESTDIR`, in this case we need to use
  85. # `prefix`. Only `/usr/bin` and `/usr/man` are installed, so it is
  86. # enough to specify `$PKG/usr`.
  87. ###sbolint on
  88. make
  89. make install prefix=$PKG/usr
  90. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  91. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  92. find $PKG/usr/man -type f -exec gzip -9 {} \;
  93. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  94. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  95. cp -a \
  96. CHANGES COPYING GPL README \
  97. $([ "$DISABLE_DOC" = "yes" ] || echo manual.pdf manual.html) \
  98. $PKG/usr/doc/$PRGNAM-$VERSION
  99. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  100. mkdir -p $PKG/install
  101. cat $CWD/slack-desc > $PKG/install/slack-desc
  102. cd $PKG
  103. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE