tvheadend.SlackBuild 4.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136
  1. #!/bin/bash
  2. # Slackware build script for tvheadend
  3. # Copyright 2015 William PC (Slack-it), Seattle - USA
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # 20220216 bkw: Modified by SlackBuilds.org:
  23. # - stop trying to download files from the SlackBuild. our scripts must
  24. # run without network access.
  25. # - fix build for latest libhdhomerun.
  26. # - disable pcloud, since it fails even if we let the Makefile download it.
  27. cd $(dirname $0) ; CWD=$(pwd)
  28. PRGNAM=tvheadend
  29. VERSION=${VERSION:-4.2.8}
  30. BUILD=${BUILD:-1}
  31. TAG=${TAG:-_SBo}
  32. PKGTYPE=${PKGTYPE:-tgz}
  33. if [ -z "$ARCH" ]; then
  34. case "$( uname -m )" in
  35. i?86) ARCH=i586 ;;
  36. arm*) ARCH=arm ;;
  37. *) ARCH=$( uname -m ) ;;
  38. esac
  39. fi
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. DATAVER=${DATAVER:-$VERSION}
  62. HDHRVER=${HDHRVER:-20210624}
  63. rm -rf $PKG
  64. mkdir -p $TMP $PKG $OUTPUT
  65. cd $TMP
  66. rm -rf $PRGNAM-$VERSION
  67. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  68. tar xvf $CWD/$PRGNAM-$VERSION-data-dvb-scan.tar.xz
  69. cd $PRGNAM-$VERSION
  70. chown -R root:root .
  71. find -L . \
  72. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  73. -o -perm 511 \) -exec chmod 755 {} \+ -o \
  74. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  75. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \+
  76. patch -p1 < $CWD/tvheadend-4.2.8-gcc9.patch
  77. patch -p1 < $CWD/tvheadend-4.2.8-fno-common.patch
  78. # 20220216 bkw: use latest libhdhomerun
  79. patch -p1 < $CWD/libhdhomerun.diff
  80. SLKCFLAGS+=" -DHDHOMERUN_TAG_DEVICE_AUTH_BIN=HDHOMERUN_TAG_DEVICE_AUTH_BIN_DEPRECATED"
  81. CFLAGS="$SLKCFLAGS" \
  82. CXXFLAGS="$SLKCFLAGS" \
  83. ./configure \
  84. --prefix=/usr \
  85. --libdir=/usr/lib${LIBDIRSUFFIX} \
  86. --mandir=/usr/man \
  87. --docdir=/usr/doc/$PRGNAM-$VERSION \
  88. --disable-ffmpeg_static \
  89. --disable-libx264_static \
  90. --disable-libx265_static \
  91. --disable-libvpx_static \
  92. --disable-libtheora_static \
  93. --disable-libvorbis_static \
  94. --disable-libfdkaac_static \
  95. --python=python3 \
  96. --disable-pcloud_cache \
  97. --nowerror \
  98. --build=$ARCH-slackware-linux
  99. make V=1 TVHEADEND_FILE_CACHE=$CWD
  100. make install DESTDIR=$PKG
  101. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  102. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  103. find $PKG/usr/man -type f -exec gzip -9 {} \;
  104. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  105. rm -f $PKG/usr/info/dir
  106. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  107. cp -a docs $PKG/usr/doc/$PRGNAM-$VERSION
  108. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  109. mkdir -p $PKG/install
  110. cat $CWD/slack-desc > $PKG/install/slack-desc
  111. cd $PKG
  112. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE