opengrads.SlackBuild 3.2 KB

1234567891011121314151617181920212223242526272829303132333435363738394041424344454647484950515253545556575859606162636465666768697071727374757677787980818283848586878889909192939495
  1. #!/bin/bash
  2. # Slackware build script for OpenGrADS
  3. # Copyright 2009 Eduardo Oda
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Written by Oda - edu.oda@gmail.com
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=opengrads
  25. VERSION=${VERSION:-2.0.1.oga.1}
  26. ARCH=${ARCH:-i686}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  31. # the name of the created package would be, and then exit. This information
  32. # could be useful to other scripts.
  33. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  34. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  35. exit 0
  36. fi
  37. TMP=${TMP:-/tmp/SBo}
  38. PKG=$TMP/package-$PRGNAM
  39. OUTPUT=${OUTPUT:-/tmp}
  40. set -e
  41. if [ "$ARCH" != "x86_64" ]; then
  42. # Just in case someone has ARCH=i486 set in the environment
  43. ARCH=i686
  44. fi
  45. rm -rf $PKG
  46. mkdir -p $PKG/opt $OUTPUT
  47. tar xvf grads-$VERSION-bundle-$ARCH-*-linux-gnu.tar.gz -C $PKG/opt
  48. cd $PKG/opt
  49. chown -R root:root grads-$VERSION
  50. # Let's use an unversioned install directory for less noisy upgrades
  51. mv grads-$VERSION opengrads
  52. # and then symlink to replicate the original directory structure
  53. ln -s opengrads grads-$VERSION
  54. cd opengrads
  55. find -L . \
  56. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
  57. -exec chmod 755 {} \; -o \
  58. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  59. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  60. find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
  61. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  62. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  63. ( cd $PKG/usr/doc/$PRGNAM-$VERSION
  64. ln -s ../../../opt/opengrads/COPYRIGHT .
  65. ln -s ../../../opt/opengrads/INSTALL .
  66. ln -s ../../../opt/opengrads/NEWS .
  67. ln -s ../../../opt/opengrads/README .
  68. ln -s ../../../opt/opengrads/Contents/Resources/Documentation .
  69. )
  70. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  71. mkdir -p $PKG/etc/profile.d
  72. cp $CWD/opengrads.sh $PKG/etc/profile.d/opengrads.sh
  73. cp $CWD/opengrads.csh $PKG/etc/profile.d/opengrads.csh
  74. chmod 0755 $PKG/etc/profile.d/*
  75. mkdir -p $PKG/install
  76. cat $CWD/slack-desc > $PKG/install/slack-desc
  77. cd $PKG
  78. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE