OTB.SlackBuild 5.1 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168
  1. #!/bin/bash
  2. # SlackBuild script for OTB
  3. # Copyright 2014-2021 Benjamin Trigona-Harany <slackbuilds@jaxartes.net>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use in source and binary forms, with or without
  7. # modification, are permitted provided that the following conditions are
  8. # met:
  9. #
  10. # * Redistributions of source code must retain the above copyright
  11. # notice, this list of conditions and the following disclaimer.
  12. #
  13. # THIS SOFTWARE IS PROVIDED BY THE COPYRIGHT HOLDERS AND CONTRIBUTORS
  14. # "AS IS" AND ANY EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT
  15. # LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR
  16. # A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE COPYRIGHT
  17. # OWNER OR CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  18. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT
  19. # LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE,
  20. # DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY
  21. # THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
  22. # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE
  23. # OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  24. cd $(dirname $0) ; CWD=$(pwd)
  25. PRGNAM=OTB
  26. VERSION=${VERSION:-7.3.0}
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. if [ "$ARCH" = "i586" ]; then
  48. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  49. LIBDIRSUFFIX=""
  50. elif [ "$ARCH" = "i686" ]; then
  51. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  52. LIBDIRSUFFIX=""
  53. elif [ "$ARCH" = "x86_64" ]; then
  54. SLKCFLAGS="-O2 -fPIC"
  55. LIBDIRSUFFIX="64"
  56. else
  57. SLKCFLAGS="-O2"
  58. LIBDIRSUFFIX=""
  59. fi
  60. set -e
  61. rm -rf $PKG
  62. mkdir -p $TMP $PKG $OUTPUT
  63. cd $TMP
  64. rm -rf $PRGNAM-$VERSION
  65. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  66. cd $PRGNAM-$VERSION
  67. chown -R root:root .
  68. find -L . \
  69. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  70. -o -perm 511 \) -exec chmod 755 {} \; -o \
  71. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  72. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  73. sed -i "s/lib\b/lib${LIBDIRSUFFIX}/" \
  74. CMakeLists.txt \
  75. CMake/OTBModuleExternal.cmake \
  76. CMake/OTBStandaloneModuleMacros.cmake \
  77. CMake/OTBApplicationMacros.cmake
  78. sed -i '1i\using namespace std;' \
  79. Modules/ThirdParty/OssimPlugins/src/gdal/*.cpp \
  80. Modules/ThirdParty/OssimPlugins/src/ossim/*.{h,cpp} \
  81. Modules/ThirdParty/OssimPlugins/src/ossim/otb/*.cpp \
  82. Modules/Adapters/OSSIMAdapters/src/*.cxx
  83. sed -i "s/[{]0.0[}]//" \
  84. Modules/{Learning,Segmentation,Filtering,Registration}/*/include/*.h \
  85. Modules/Core/Common/include/otbImageRegionAdaptativeSplitter.h \
  86. Modules/Core/Transform/include/otbImageToGenericRSOutputParameters.h
  87. MONTEVERDI=${MONTEVERDI:-OFF}
  88. BUILD_MONTEVERDI="-DOTB_USE_QWT=$MONTEVERDI -DOTB_USE_GLEW=$MONTEVERDI -DOTB_USE_OPENGL=$MONTEVERDI"
  89. BUILD_QT="-DOTB_USE_QT=${QTGUI:-ON}"
  90. mkdir -p build
  91. cd build
  92. cmake \
  93. -DCMAKE_BUILD_TYPE=Release \
  94. -DCMAKE_C_FLAGS="$SLKCFLAGS" \
  95. -DCMAKE_CXX_FLAGS="$SLKCFLAGS" \
  96. -DCMAKE_INSTALL_PREFIX=/usr \
  97. -DBUILD_EXAMPLES=OFF \
  98. -DBUILD_TESTING=OFF \
  99. -DOTB_USE_CURL=ON \
  100. -DOTB_USE_GLUT=ON \
  101. -DOTB_USE_GSL=ON \
  102. -DOTB_USE_LIBKML=ON \
  103. -DOTB_USE_MUPARSER=ON \
  104. -DOTB_USE_OPENCV=ON \
  105. -DOTB_USE_OPENMP=ON \
  106. -DOTB_USE_SHARK=ON \
  107. -DOTB_INSTALL_PYTHON_DIR=$(python3 -c "from distutils.sysconfig import get_python_lib; print(get_python_lib())") \
  108. -DOTB_WRAP_PYTHON=ON \
  109. -DOTB_INSTALL_DOC_DIR=doc/$PRGNAM-$VERSION \
  110. -DGDAL_CONFIG_CHECKING=OFF \
  111. $BUILD_MONTEVERDI \
  112. $BUILD_QT \
  113. ..
  114. make install DESTDIR=$PKG
  115. cd ..
  116. if [ "$QTGUI" = "OFF" ] ; then
  117. # otbgui scripts are added but are unusable
  118. rm $PKG/usr/bin/otbgui_*
  119. fi
  120. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  121. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  122. mkdir -p $PKG/etc/profile.d
  123. cat > $PKG/etc/profile.d/otb.csh << EOF
  124. #!/bin/csh
  125. # Orfeo ToolBox applications path
  126. setenv OTB_APPLICATION_PATH /usr/lib${LIBDIRSUFFIX}/otb/applications
  127. EOF
  128. cat > $PKG/etc/profile.d/otb.sh << EOF
  129. #!/bin/sh
  130. # Orfeo ToolBox applications path
  131. export OTB_APPLICATION_PATH=/usr/lib${LIBDIRSUFFIX}/otb/applications
  132. EOF
  133. chmod 0755 $PKG/etc/profile.d/otb.csh
  134. chmod 0755 $PKG/etc/profile.d/otb.sh
  135. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  136. cp -a \
  137. README.md RELEASE_NOTES.txt \
  138. $PKG/usr/doc/$PRGNAM-$VERSION
  139. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  140. mkdir -p $PKG/install
  141. cat $CWD/slack-desc > $PKG/install/slack-desc
  142. if [ "$MONTEVERDI" = "ON" ] ; then
  143. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  144. fi
  145. cd $PKG
  146. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE