wminfo.SlackBuild 2.7 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101
  1. #!/bin/bash
  2. # Slackware build script for wminfo
  3. # Written by Cezary M. Kruk (c.kruk@bigfoot.com)
  4. #
  5. # Modified by the SlackBuilds.org project.
  6. cd $(dirname $0) ; CWD=$(pwd)
  7. PRGNAM=wminfo
  8. VERSION=${VERSION:-4.2.1}
  9. BUILD=${BUILD:-1}
  10. TAG=${TAG:-_SBo}
  11. PKGTYPE=${PKGTYPE:-tgz}
  12. if [ -z "$ARCH" ]; then
  13. case "$( uname -m )" in
  14. i?86) ARCH=i486 ;;
  15. arm*) ARCH=arm ;;
  16. *) ARCH=$( uname -m ) ;;
  17. esac
  18. fi
  19. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  20. # the name of the created package would be, and then exit. This information
  21. # could be useful to other scripts.
  22. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  23. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  24. exit 0
  25. fi
  26. TMP=${TMP:-/tmp/SBo}
  27. PKG=$TMP/package-$PRGNAM
  28. OUTPUT=${OUTPUT:-/tmp}
  29. if [ "$ARCH" = "i486" ]; then
  30. SLKCFLAGS="-O2 -march=i486 -mtune=i686"
  31. LIBDIRSUFFIX=""
  32. elif [ "$ARCH" = "i686" ]; then
  33. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  34. LIBDIRSUFFIX=""
  35. elif [ "$ARCH" = "x86_64" ]; then
  36. SLKCFLAGS="-O2 -fPIC"
  37. LIBDIRSUFFIX="64"
  38. else
  39. SLKCFLAGS="-O2"
  40. LIBDIRSUFFIX=""
  41. fi
  42. set -e
  43. rm -rf $PKG
  44. mkdir -p $TMP $PKG $OUTPUT
  45. cd $TMP
  46. rm -rf $PRGNAM-$VERSION
  47. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  48. cd $PRGNAM-$VERSION
  49. chown -R root:root .
  50. find -L . \
  51. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  52. -o -perm 511 \) -exec chmod 755 {} \; -o \
  53. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  54. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  55. cd wminfo
  56. ./configure --prefix=/usr
  57. make \
  58. LIBDIR="-L/usr/lib${LIBDIRSUFFIX}/X11" \
  59. CFLAGS="$SLKCFLAGS -fgnu89-inline -fcommon"
  60. # Copy executable to the correct location
  61. mkdir -p $PKG/usr/bin
  62. cp -a wminfo $PKG/usr/bin
  63. cp -a regex $PKG/usr/bin
  64. cp -a ../contrib/* $PKG/usr/bin
  65. chmod 0755 $PKG/usr/bin/*
  66. rm $PKG/usr/bin/README.*
  67. cd -
  68. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  69. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  70. mkdir -p $PKG/usr/man/man1
  71. cp -a man/wminfo.1 $PKG/usr/man/man1
  72. gzip -9 $PKG/usr/man/man1/wminfo.1
  73. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  74. cp -a BUGS COPYING ChangeLog INSTALL Plugins-HOWTO README README.1st README.CPU.usage \
  75. README.benchmarks README.colors README.multi+wrapper README.regex README.plugin.rerun \
  76. THANKS TODO contrib plugins.binary plugins.conky plugins.offline plugins.online \
  77. plugins.system-1 plugins.system-2 samples \
  78. $PKG/usr/doc/$PRGNAM-$VERSION
  79. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  80. mkdir -p $PKG/install
  81. cat $CWD/slack-desc > $PKG/install/slack-desc
  82. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  83. cd $PKG
  84. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE