123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146 |
- #!/bin/bash
- # Slackware build script for wmii
- # Now maintained by Dave Woodfall <dave@slackbuilds.org>
- # Copyright (c) 2011, Marco Bonetti <sid77@slackware.it>
- # All rights reserved.
- # Maintenance adopted 11.02.2015 Glenn Becker <glenn.becker@gmail.com>
- #
- # Redistribution and use in source and binary forms, with or without
- # modification, are permitted provided that the following conditions are met:
- # 1.- Redistributions of source code must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR ``AS IS'' AND ANY
- # EXPRESS OR IMPLIED WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED
- # WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE
- # DISCLAIMED. IN NO EVENT SHALL THE AUTHOR BE LIABLE FOR ANY
- # DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES
- # (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES;
- # LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND
- # ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
- # (INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
- # SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Thanks to selkfoster <selkfoster@gmail.com>
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=wmii
- SRCNAM=wmii+ixp
- VERSION=${VERSION:-3.9.2}
- BUILD=${BUILD:-4}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
- # the name of the created package would be, and then exit. This information
- # could be useful to other scripts.
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ]; then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ]; then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $SRCNAM-$VERSION
- tar xvf $CWD/$SRCNAM-$VERSION.tbz
- cd $SRCNAM-$VERSION
- chown -R root:root .
- find -L . \
- \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 -o -perm 511 \) \
- -exec chmod 755 {} \; -o \
- \( -perm 666 -o -perm 664 -o -perm 600 -o -perm 444 -o -perm 440 -o -perm 400 \) \
- -exec chmod 644 {} \;
- # Fixup config.mk
- patch -p1 < $CWD/wmii-3.9.2-config_mk.diff
- # Fixup mk/hdr.mk
- patch -p1 < $CWD/wmii-3.9.2-mk_hdr_mk.diff
- # Fix the man pages
- sed -zi 's,\.P[^@]@DOCDIR@/wmii\.pdf,,' man/wmii.1
- sed -i "s,@DOCDIR@,/usr/doc/$PRGNAM-$VERSION,g" man/wmii.1
- sed -i "s,@CONFPREFIX@,/etc,g" man/wmii.1
- export CFLAGS="$SLKCFLAGS -fcommon"
- LDFLAGS="-lX11 -lXrender" \
- make \
- OPT="$SLKCFLAGS" \
- PREFIX=/usr \
- MAN=/usr/man \
- ETC=/etc \
- DOC=/usr/doc/$PRGNAM-$VERSION \
- LIBDIRSUFFIX=${LIBDIRSUFFIX}
- make install \
- OPT="$SLKCFLAGS" \
- PREFIX=$PKG/usr \
- MAN=$PKG/usr/man \
- ETC=$PKG/etc \
- DOC=$PKG/usr/doc/$PRGNAM-$VERSION \
- LIBDIRSUFFIX=${LIBDIRSUFFIX}
- # Add wmii to xwmconfig's list...
- install -D -m 0755 $CWD/xinitrc.wmii $PKG/etc/X11/xinit/xinitrc.wmii
- # ...and the required startup script
- install -D -m 0755 $CWD/wmii.xinit $PKG/usr/bin/wmii.xinit
- # Add a simple wmii.desktop so it can be started from kdm
- install -D -m 0644 $CWD/wmii.desktop $PKG/usr/share/apps/kdm/sessions/wmii.desktop
- # Don't clobber config files
- mv $PKG/etc/wmii/welcome $PKG/etc/wmii/welcome.new
- mv $PKG/etc/wmii/wmiirc $PKG/etc/wmii/wmiirc.new
- mv $PKG/etc/wmii/plan9port/wmiirc $PKG/etc/wmii/plan9port/wmiirc.new
- mv $PKG/etc/wmii/python/wmiirc $PKG/etc/wmii/python/wmiirc.new
- mv $PKG/etc/wmii/ruby/wmiirc $PKG/etc/wmii/ruby/wmiirc.new
- find $PKG | xargs file | grep -e "executable" -e "shared object" | grep ELF \
- | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
- find $PKG/usr/man -type f -exec gzip -9 {} \;
- cp -a LICENSE README $PKG/usr/doc/$PRGNAM-$VERSION
- # The directories were there, but no files
- cp -r alternative_wmiircs $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- # hmm?
- #( cd $PKG/usr/doc ; ln -s $PRGNAM-$VERSION $PRGNAM )
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cat $CWD/doinst.sh > $PKG/install/doinst.sh
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|