wmbutton.SlackBuild 3.3 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119
  1. #!/bin/bash
  2. # Slackware build script for <wmbutton>
  3. # Copyright <2018> <Michael Heras> <USA>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Now maintained by B. Watson <yalhcru@gmail.com>.
  23. # 20220208 bkw: BUILD=2
  24. # - take over maintenance.
  25. # - add icon.
  26. cd $(dirname $0) ; CWD=$(pwd)
  27. PRGNAM=wmbutton
  28. VERSION=${VERSION:-0.7.1}
  29. BUILD=${BUILD:-2}
  30. TAG=${TAG:-_SBo}
  31. PKGTYPE=${PKGTYPE:-tgz}
  32. if [ -z "$ARCH" ]; then
  33. case "$( uname -m )" in
  34. i?86) ARCH=i586 ;;
  35. arm*) ARCH=arm ;;
  36. *) ARCH=$( uname -m ) ;;
  37. esac
  38. fi
  39. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  40. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  41. exit 0
  42. fi
  43. TMP=${TMP:-/tmp/SBo}
  44. PKG=$TMP/package-$PRGNAM
  45. OUTPUT=${OUTPUT:-/tmp}
  46. if [ "$ARCH" = "i586" ]; then
  47. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  48. LIBDIRSUFFIX=""
  49. elif [ "$ARCH" = "i686" ]; then
  50. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  51. LIBDIRSUFFIX=""
  52. elif [ "$ARCH" = "x86_64" ]; then
  53. SLKCFLAGS="-O2 -fPIC"
  54. LIBDIRSUFFIX="64"
  55. else
  56. SLKCFLAGS="-O2"
  57. LIBDIRSUFFIX=""
  58. fi
  59. set -e
  60. rm -rf $PKG
  61. mkdir -p $TMP $PKG $OUTPUT
  62. cd $TMP
  63. rm -rf $PRGNAM-$VERSION
  64. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  65. cd $PRGNAM-$VERSION
  66. chown -R root:root .
  67. find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
  68. \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
  69. echo "Icon=$PRGNAM" >> $PRGNAM.desktop
  70. CFLAGS="$SLKCFLAGS" \
  71. CXXFLAGS="$SLKCFLAGS" \
  72. ./configure \
  73. --prefix=/usr \
  74. --libdir=/usr/lib${LIBDIRSUFFIX} \
  75. --sysconfdir=/etc \
  76. --localstatedir=/var \
  77. --mandir=/usr/man \
  78. --docdir=/usr/doc/$PRGNAM-$VERSION \
  79. --build=$ARCH-slackware-linux
  80. make
  81. make install-strip DESTDIR=$PKG
  82. gzip -9 $PKG/usr/man/man*/*
  83. mv $PKG/etc/wmbutton.conf $PKG/etc/wmbutton.conf.new
  84. mkdir -p $PKG/usr/share/icons/hicolor/64x64/apps \
  85. $PKG/usr/share/pixmaps
  86. convert -extent 64x64 -background none -gravity center \
  87. icons/buttons2.xpm \
  88. $PKG/usr/share/icons/hicolor/64x64/apps/$PRGNAM.png
  89. ln -s ../icons/hicolor/64x64/apps/$PRGNAM.png $PKG/usr/share/pixmaps/$PRGNAM.png
  90. PKGDOC=$PKG/usr/doc/$PRGNAM-$VERSION
  91. mkdir -p $PKGDOC
  92. cp -a COPYING ChangeLog README $PKGDOC
  93. cat $CWD/$PRGNAM.SlackBuild > $PKGDOC/$PRGNAM.SlackBuild
  94. mkdir -p $PKG/install
  95. cat $CWD/slack-desc > $PKG/install/slack-desc
  96. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  97. cd $PKG
  98. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE