weston.SlackBuild 5.0 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120121122123124125126127128129130131132133134135136137138139140141142143144145146147148149150151152153154155156157158159160161162163164165166167168169170171172173174175176177178179180181182183184185186
  1. #!/bin/bash
  2. # Slackware build script for Weston
  3. # Copyright 2019-2022 Logan Rathbone <poprocks@gmail.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. cd $(dirname $0) ; CWD=$(pwd)
  23. PRGNAM=weston
  24. VERSION=${VERSION:-10.0.0}
  25. BUILD=${BUILD:-1}
  26. TAG=${TAG:-_SBo}
  27. PKGTYPE=${PKGTYPE:-tgz}
  28. if [ -z "$ARCH" ]; then
  29. case "$( uname -m )" in
  30. i?86) ARCH=i586 ;;
  31. arm*) ARCH=arm ;;
  32. *) ARCH=$( uname -m ) ;;
  33. esac
  34. fi
  35. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  36. # the name of the created package would be, and then exit. This information
  37. # could be useful to other scripts.
  38. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  39. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  40. exit 0
  41. fi
  42. TMP=${TMP:-/tmp/SBo}
  43. PKG=$TMP/package-$PRGNAM
  44. OUTPUT=${OUTPUT:-/tmp}
  45. if [ "$ARCH" = "i586" ]; then
  46. SLKCFLAGS="-O2 -march=i586 -mtune=i686"
  47. LIBDIRSUFFIX=""
  48. elif [ "$ARCH" = "i686" ]; then
  49. SLKCFLAGS="-O2 -march=i686 -mtune=i686"
  50. LIBDIRSUFFIX=""
  51. elif [ "$ARCH" = "x86_64" ]; then
  52. SLKCFLAGS="-O2 -fPIC"
  53. LIBDIRSUFFIX="64"
  54. else
  55. SLKCFLAGS="-O2"
  56. LIBDIRSUFFIX=""
  57. fi
  58. set -e
  59. rm -rf $PKG
  60. mkdir -p $TMP $PKG $OUTPUT
  61. cd $TMP
  62. rm -rf $PRGNAM-$VERSION
  63. tar xvf $CWD/$PRGNAM-$VERSION.tar.gz
  64. cd $PRGNAM-$VERSION
  65. # Patches
  66. patch -p1 < $CWD/weston-10.0.0-elogind.patch
  67. # Make sure ownerships and permissions are sane:
  68. chown -R root:root .
  69. find -L . \
  70. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  71. -o -perm 511 \) -exec chmod 755 {} \; -o \
  72. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  73. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  74. # nb: pipewire is disabled for now as >= 0.3 not yet supported
  75. mkdir build
  76. cd build
  77. CFLAGS="$SLKCFLAGS" \
  78. CXXFLAGS="$SLKCFLAGS" \
  79. meson .. \
  80. --prefix=/usr \
  81. --mandir=man \
  82. --libdir=lib${LIBDIRSUFFIX} \
  83. -Dsystemd=false \
  84. -Dcolor-management-colord=${USE_COLORD:-false}
  85. ninja
  86. DESTDIR=$PKG ninja install
  87. cd ..
  88. # strip
  89. find $PKG -print0 | xargs -0 file | grep -e "executable" -e "shared object" | grep ELF \
  90. | cut -f 1 -d : | xargs strip --strip-unneeded 2> /dev/null || true
  91. find $PKG/usr/man -type f -exec gzip -9 {} \;
  92. for i in $( find $PKG/usr/man -type l ) ; do ln -s $( readlink $i ).gz $i.gz ; rm $i ; done
  93. # Install /etc/profile.d scripts.
  94. mkdir -p $PKG/etc/profile.d/
  95. cat << 'EOF' > $PKG/etc/profile.d/${PRGNAM}.sh.new
  96. #!/bin/sh
  97. if test -z "${XDG_RUNTIME_DIR}"; then
  98. export XDG_RUNTIME_DIR=/tmp/${UID}-runtime-dir
  99. if ! test -d "${XDG_RUNTIME_DIR}"; then
  100. mkdir "${XDG_RUNTIME_DIR}"
  101. chmod 0700 "${XDG_RUNTIME_DIR}"
  102. fi
  103. fi
  104. EOF
  105. cat << 'EOF' > $PKG/etc/profile.d/${PRGNAM}.csh.new
  106. #!/bin/csh
  107. if ( ! $?XDG_RUNTIME_DIR ) then
  108. setenv XDG_RUNTIME_DIR /tmp/${uid}-runtime-dir
  109. if ( ! -d $XDG_RUNTIME_DIR ) then
  110. mkdir "${XDG_RUNTIME_DIR}"
  111. chmod 0700 "${XDG_RUNTIME_DIR}"
  112. endif
  113. endif
  114. EOF
  115. chmod 644 $PKG/etc/profile.d/${PRGNAM}*.new
  116. # setup doinst script...
  117. mkdir -p $PKG/install
  118. cat << 'EOF' > $PKG/install/doinst.sh
  119. config() {
  120. NEW="$1"
  121. OLD="$(dirname $NEW)/$(basename $NEW .new)"
  122. # If there's no config file by that name, mv it over:
  123. if [ ! -r $OLD ]; then
  124. mv $NEW $OLD
  125. elif [ "$(cat $OLD | md5sum)" = "$(cat $NEW | md5sum)" ]; then
  126. # toss the redundant copy
  127. rm $NEW
  128. fi
  129. # Otherwise, we leave the .new copy for the admin to consider...
  130. }
  131. preserve_perms() {
  132. NEW="$1"
  133. OLD="$(dirname $NEW)/$(basename $NEW .new)"
  134. if [ -e $OLD ]; then
  135. cp -a $OLD ${NEW}.incoming
  136. cat $NEW > ${NEW}.incoming
  137. mv ${NEW}.incoming $NEW
  138. fi
  139. config $NEW
  140. }
  141. EOF
  142. # config-ify the profile.d stuff
  143. cat << EOF >> $PKG/install/doinst.sh
  144. preserve_perms etc/profile.d/${PRGNAM}.sh.new
  145. preserve_perms etc/profile.d/${PRGNAM}.csh.new
  146. EOF
  147. # Install some documentation and finish up.
  148. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  149. cp -a CONTRIBUTING.md COPYING DCO-1.1.txt README.md notes.txt $PKG/usr/doc/$PRGNAM-$VERSION
  150. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  151. cat $CWD/slack-desc > $PKG/install/slack-desc
  152. cd $PKG
  153. /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE