123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111112113114115116117118119120 |
- #!/bin/bash
- # Slackware build script for trayer-srg
- # Copyright 2013 Bojan Popovic Belgrade Serbia
- # All rights reserved.
- #
- # Redistribution and use of this script, with or without modification, is
- # permitted provided that the following conditions are met:
- #
- # 1. Redistributions of this script must retain the above copyright
- # notice, this list of conditions and the following disclaimer.
- #
- # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
- # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
- # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
- # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
- # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
- # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
- # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
- # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
- # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
- # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
- # Now maintained by B. Watson (yalhcru@gmail.com)
- # 20210907 bkw: BUILD=2, spelling/grammar fixes in docs.
- # 20180612 bkw: updated for v1.1.8.
- # 20170708 bkw:
- # - updated for v1.1.7.
- # - stop installing INSTALL in doc dir.
- # 20170122 bkw:
- # - updated for latest git.
- # 20150111 bkw:
- # - Updated for latest git. Switching from git hash as version number to the
- # date of the last commit as found by 'git log'. At least you can compare
- # dates just by looking at them.
- # - Upstream now uses a (non-autotools) ./configure script.
- cd $(dirname $0) ; CWD=$(pwd)
- PRGNAM=trayer-srg
- VERSION=${VERSION:-1.1.8}
- BUILD=${BUILD:-2}
- TAG=${TAG:-_SBo}
- PKGTYPE=${PKGTYPE:-tgz}
- if [ -z "$ARCH" ]; then
- case "$( uname -m )" in
- i?86) ARCH=i586 ;;
- arm*) ARCH=arm ;;
- *) ARCH=$( uname -m ) ;;
- esac
- fi
- if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
- echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
- exit 0
- fi
- TMP=${TMP:-/tmp/SBo}
- PKG=$TMP/package-$PRGNAM
- OUTPUT=${OUTPUT:-/tmp}
- if [ "$ARCH" = "i586" ];then
- SLKCFLAGS="-O2 -march=i586 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "i686" ];then
- SLKCFLAGS="-O2 -march=i686 -mtune=i686"
- LIBDIRSUFFIX=""
- elif [ "$ARCH" = "x86_64" ]; then
- SLKCFLAGS="-O2 -fPIC"
- LIBDIRSUFFIX="64"
- else
- SLKCFLAGS="-O2"
- LIBDIRSUFFIX=""
- fi
- set -e
- #TARNAM="${PRGNAM}-trayer" # for old versions
- TARNAM="${PRGNAM}-trayer"
- rm -rf $PKG
- mkdir -p $TMP $PKG $OUTPUT
- cd $TMP
- rm -rf $TARNAM-$VERSION
- tar xvf $CWD/$TARNAM-$VERSION.tar.?z*
- cd $TARNAM-$VERSION
- chown -R root:root .
- find -L . -perm /111 -a \! -perm 755 -a -exec chmod 755 {} \+ -o \
- \! -perm /111 -a \! -perm 644 -a -exec chmod 644 {} \+
- patch -p1 < $CWD/spelling_grammar_fixes.diff
- # not a real (autotools) configure script, notice non-canonical use
- # of --prefix here!
- ./configure --prefix=/usr/bin
- CFLAGS="$SLKCFLAGS" make # This will also strip the executable
- # Instead of patching the Makefile, let's install it manually:
- mkdir -p $PKG/usr/bin
- install -m 0755 trayer $PKG/usr/bin
- mkdir -p $PKG/usr/man/man1
- gzip -c man/trayer.1 > $PKG/usr/man/man1/trayer.1.gz
- mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
- cp -a CHANGELOG COPYING CREDITS README TODO $PKG/usr/doc/$PRGNAM-$VERSION
- cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
- mkdir -p $PKG/install
- cat $CWD/slack-desc > $PKG/install/slack-desc
- cd $PKG
- /sbin/makepkg -l y -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE
|