tauonmb.SlackBuild 3.6 KB

123456789101112131415161718192021222324252627282930313233343536373839404142434445464748495051525354555657585960616263646566676869707172737475767778798081828384858687888990919293949596979899100101102103104105106107108109110111
  1. #!/bin/bash
  2. # Slackware build script for Tauon Music Box
  3. # Copyright 2019-2022 Pouria Rezaei <Pouria.rz@outlook.com>
  4. # All rights reserved.
  5. #
  6. # Redistribution and use of this script, with or without modification, is
  7. # permitted provided that the following conditions are met:
  8. #
  9. # 1. Redistributions of this script must retain the above copyright
  10. # notice, this list of conditions and the following disclaimer.
  11. #
  12. # THIS SOFTWARE IS PROVIDED BY THE AUTHOR "AS IS" AND ANY EXPRESS OR IMPLIED
  13. # WARRANTIES, INCLUDING, BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF
  14. # MERCHANTABILITY AND FITNESS FOR A PARTICULAR PURPOSE ARE DISCLAIMED. IN NO
  15. # EVENT SHALL THE AUTHOR BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL,
  16. # SPECIAL, EXEMPLARY, OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO,
  17. # PROCUREMENT OF SUBSTITUTE GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS;
  18. # OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON ANY THEORY OF LIABILITY,
  19. # WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE OR
  20. # OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF
  21. # ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
  22. # Modified by the SlackBuilds.org project
  23. cd $(dirname $0) ; CWD=$(pwd)
  24. PRGNAM=tauonmb
  25. VERSION=${VERSION:-7.1.3}
  26. SRCNAM=TauonMusicBox
  27. BUILD=${BUILD:-1}
  28. TAG=${TAG:-_SBo}
  29. PKGTYPE=${PKGTYPE:-tgz}
  30. if [ -z "$ARCH" ]; then
  31. case "$( uname -m )" in
  32. i?86) ARCH=i586 ;;
  33. arm*) ARCH=arm ;;
  34. *) ARCH=$( uname -m ) ;;
  35. esac
  36. fi
  37. # If the variable PRINT_PACKAGE_NAME is set, then this script will report what
  38. # the name of the created package would be, and then exit. This information
  39. # could be useful to other scripts.
  40. if [ ! -z "${PRINT_PACKAGE_NAME}" ]; then
  41. echo "$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE"
  42. exit 0
  43. fi
  44. TMP=${TMP:-/tmp/SBo}
  45. PKG=$TMP/package-$PRGNAM
  46. OUTPUT=${OUTPUT:-/tmp}
  47. set -e
  48. rm -rf $PKG
  49. mkdir -p $TMP $PKG $OUTPUT
  50. cd $TMP
  51. rm -rf $SRCNAM-$VERSION
  52. tar xvf $CWD/$SRCNAM-$VERSION.tar.gz
  53. cd $SRCNAM-$VERSION
  54. chown -R root:root .
  55. find -L . \
  56. \( -perm 777 -o -perm 775 -o -perm 750 -o -perm 711 -o -perm 555 \
  57. -o -perm 511 \) -exec chmod 755 {} \; -o \
  58. \( -perm 666 -o -perm 664 -o -perm 640 -o -perm 600 -o -perm 444 \
  59. -o -perm 440 -o -perm 400 \) -exec chmod 644 {} \;
  60. # Build phazor
  61. gcc src/phazor/kissfft/kiss_fftr.c src/phazor/kissfft/kiss_fft.c src/phazor/phazor.c \
  62. `pkg-config --cflags --libs samplerate libpulse-simple opusfile vorbisfile libmpg123 flac libopenmpt` \
  63. -shared -o libphazor.so -fPIC -Wall -O3 # -Wextra
  64. mkdir -p lib
  65. mv libphazor.so lib/libphazor.so
  66. # Compile translator
  67. python3 compile-translations.py
  68. rm -fR locale/*/*/tauon.po compile* mac.spec requirements.txt \
  69. snapcraft.yaml src update-translations.py
  70. mkdir -p $PKG/opt/tauon-music-box $PKG/usr/bin
  71. mv * $PKG/opt/tauon-music-box
  72. install -m 0755 $PKG/opt/tauon-music-box/extra/$PRGNAM.sh \
  73. $PKG/opt/tauon-music-box/$PRGNAM.sh
  74. ln -s /opt/tauon-music-box/$PRGNAM.sh $PKG/usr/bin/tauon
  75. cd $PKG/opt/tauon-music-box
  76. mkdir -p $PKG/usr/share/applications
  77. cp extra/$PRGNAM.desktop $PKG/usr/share/applications/
  78. mv locale $PKG/usr/share/
  79. mkdir -p $PKG/usr/share/icons/hicolor/{scalable,symbolic}/apps
  80. cp extra/$PRGNAM.svg $PKG/usr/share/icons/hicolor/scalable/apps/
  81. cp extra/$PRGNAM-symbolic.svg $PKG/usr/share/icons/hicolor/symbolic/apps/
  82. rm -fR extra
  83. mkdir -p $PKG/usr/doc/$PRGNAM-$VERSION
  84. mv *.md CHANGELOG LICENSE $PKG/usr/doc/$PRGNAM-$VERSION
  85. cat $CWD/$PRGNAM.SlackBuild > $PKG/usr/doc/$PRGNAM-$VERSION/$PRGNAM.SlackBuild
  86. mkdir -p $PKG/install
  87. cat $CWD/slack-desc > $PKG/install/slack-desc
  88. cat $CWD/doinst.sh > $PKG/install/doinst.sh
  89. cd $PKG
  90. /sbin/makepkg -l y -p -c n $OUTPUT/$PRGNAM-$VERSION-$ARCH-$BUILD$TAG.$PKGTYPE